LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Firefox 7.0.1 (Aurora) can't find a URL; Firefox 8.0 can! (https://www.linuxquestions.org/questions/linux-software-2/firefox-7-0-1-aurora-cant-find-a-url%3B-firefox-8-0-can-915116/)

frank4360 11-23-2011 10:16 AM

Firefox 7.0.1 (Aurora) can't find a URL; Firefox 8.0 can!
 
I have Firefox 7.0.1 Aurora running on PuupyLinux on an Acer Aspire One, and Firefox 8.0 running on Xubuntu 11.04 on another laptop.

On Firefox 8 I can access "statcounter.com"; with Firefox 7.0.1 I get "Firefox can't establish a connection".

All other sites I try seem to be available on both systems.

Any ideas, as this has beaten me!

Thanks in advance.

gRRosminet 11-23-2011 10:28 AM

Hello

Can you give a little more informations and do some checks plz :

1) Is your problem limited too statcounter ? Have you try to go to another site ?

2) Are you on the same network with your 2 PC ?

3) Have you checked your /etc/resolv.conf file ? is it the same for the 2 PC ?

4) If you try to add the following line (DNS from google) as first line of your /etc/resolv.conf, does it solve the problem ?
Quote:

nameserver 8.8.8.8
5) check your iptable rules by typing the following command as root (DNS is on port 53):
Quote:

iptables -L

frank4360 11-23-2011 10:59 AM

Quote:

Originally Posted by gRRosminet (Post 4531787)
Hello

Can you give a little more informations and do some checks plz :

1) Is your problem limited too statcounter ? Have you try to go to another site ?

2) Are you on the same network with your 2 PC ?

3) Have you checked your /etc/resolv.conf file ? is it the same for the 2 PC ?

4) If you try to add the following line (DNS from google) as first line of your /etc/resolv.conf, does it solve the problem ?


5) check your iptable rules by typing the following command as root (DNS is on port 53):

Hello

1. So far I have only found the problem with "statcounter.com" - other sites work fine.
2. Both PC's are on the same Wireless LAN
3. The /etc/resolv.conf files have the same two lines
domain home
nameserver 192.168.1.1

The system that can connect to statcounter has a line "search home" between these two line; the other system doesn't.

4. No - adding "nameserver 8.8.8.8" makes no difference

5. The system that connects has the following output to "iptables -L"

Code:

Chain INPUT (policy ACCEPT)
target    prot opt source              destination       

Chain FORWARD (policy ACCEPT)
target    prot opt source              destination       

Chain OUTPUT (policy ACCEPT)
target    prot opt source              destination

The system that doesn't connect has the following response to "iptables -L"

Code:

Chain INPUT (policy DROP)
target    prot opt source              destination       
ACCEPT    all  --  anywhere            anywhere            state RELATED,ESTABLISHED
ACCEPT    all  --  anywhere            anywhere            state NEW
TRUSTED    all  --  anywhere            anywhere            state NEW

Chain FORWARD (policy DROP)
target    prot opt source              destination       

Chain OUTPUT (policy ACCEPT)
target    prot opt source              destination       
DROP      icmp --  anywhere            anywhere            state INVALID

Chain TRUSTED (1 references)
target    prot opt source              destination       
ACCEPT    icmp --  anywhere            192.168.1.12        icmp echo-request
DROP      icmp --  anywhere            anywhere           
REJECT    all  --  anywhere            anywhere            reject-with icmp-port-unreachable


gRRosminet 11-23-2011 11:34 AM

What is 192.168.1.12 ?

did you try with WWW.statcounter.com ? ... sometimes there are strange behaviours

Try to compare output from dig (name resolver) :
Quote:

dig statcounter.com www.statcounter.com
I think you should try to reset your iptables to confirm that it is a firewall problem, but it's realy strange that only statcounter does not work :
Quote:

iptable -P INPUT ACCEPT
iptable -P OUTPUT ACCEPT
iptable -F
iptable -X
Then if it solves your problem you'll have to redefine the firewall rules you really need

John VV 11-23-2011 02:30 PM

did you install no-script and / or add block plus
both could be set to block access to starcounter

frank4360 11-24-2011 12:16 PM

I have tried both "statcounter.com" and "www.statcounter.com" - both give the same "Failed to connect" from a PuppyLinux machine; both connect perfectly from a Xubuntu system. "dig" shows both URLs work - the "www" connection is slower to make.

Both machines are on the same wireless LAN (gRRosminet - 192.168.1.12 is the PuppyLinux system) running from an Orange Livebox (192.168.1.1).

I have disabled all Firefox add-ons, running in "safe mode" - same results.

I have disabled the firewall - deleting /etc/rc.d/rc.firewall completely.

I have tried using Seamonkey browser from the PuppyLinux system - same result, so it is not a Firefox problem.

I can connect to "gs.statcounter.com" from the PuppyLinux system, but when clicking on a link to the "statcounter.com" page, the same ""Failed to connect" message appears.

I am finding the whole thing pretty baffling!

gRRosminet 11-24-2011 12:32 PM

Well ... I'm running out of ideas ...

I imagine you already have checked your livebox configuration, my neighbors often have problems with it (oui, je suis "mauvaise langue" ;-) )
So the only way to find what's wrong now is WireShark from your PuppyLinux and scan what's happening on ports 53, 80 (is that all ?) when you try to connect to statcounter.com (try to do your acces with wget so that it will limit interfernces and volume of data)

Good luck ;-)

frank4360 11-28-2011 11:26 AM

[solved]
 
As always, the simple things catch you out.

PuppyLinux seems to install a /etc/hosts file as a default, and lo and behold, "statcounter" is in this file. (/etc/hosts lists URLs that cannot be accessed by the computer - it is usually used to stop advertising).

I have simply deleted the /etc/hosts file and everything is now ok.

Thanks again.

gRRosminet 11-28-2011 01:29 PM

You should keep some lines in your /etc/hosts :

Quote:

127.0.0.1 localhost
192.168.1.12 MyPuppyMachine

frank4360 11-28-2011 02:08 PM

Yes - in fact I have just deleted all "statcounter" lines.


All times are GMT -5. The time now is 10:15 PM.