LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-25-2019, 08:41 AM   #1
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 9, LineageOS 13
Posts: 1,454

Rep: Reputation: 182Reputation: 182
Firefox 67 (Quantum) will not access the internet


Hello. I use Debian Stretch. I installed the latest Firefox from the Mozilla site (Quantum, version 67), rather than using the version that's packaged for Debian (Firefox-esr 60.7).

This morning Firefox stated it was updating, and then I was unable to access anything on the internet. I am able to access the internet with both the Konqueror browser and with Chromium (which I'm currently using). I have no idea why this is happening. If anyone has a suggestion, do please share.
 
Old 05-25-2019, 09:10 AM   #2
Contrapak
Member
 
Registered: May 2019
Location: /home/
Distribution: Arch Linux
Posts: 106

Rep: Reputation: 12
Do you have any kind firewall or anti-virus programs that could block Firefox from accessing the Internet?
 
Old 05-25-2019, 09:37 AM   #3
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 9, LineageOS 13
Posts: 1,454

Original Poster
Rep: Reputation: 182Reputation: 182
I have Gufw Firewall, version 17.04.1, installed and running. I turned it off, but that made no difference. And, I suspect if it was the firewall, that I wouldn't be able to access the web with any browser (which isn't the case).

I did notice something unusual about the addons. Beside all the active ones, I see a notation that says "ALLOWED IN PRIVATE WINDOWS" (see attached image). I tried opening Firefox in a private window, but this did not make a difference.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2019-05-25_10-30-34.png
Views:	10
Size:	132.5 KB
ID:	30644  
 
Old 05-25-2019, 09:51 AM   #4
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.6
Posts: 3,061

Rep: Reputation: 1069Reputation: 1069Reputation: 1069Reputation: 1069Reputation: 1069Reputation: 1069Reputation: 1069Reputation: 1069
Check the Network Settings within Firefox

Edit -> Preferences General scroll down to Network Settings. Settings... button

Note: That change to add-ons is new with 67.0 per the message box at the top of that page.

Last edited by scasey; 05-25-2019 at 09:53 AM.
 
Old 05-25-2019, 09:57 AM   #5
Contrapak
Member
 
Registered: May 2019
Location: /home/
Distribution: Arch Linux
Posts: 106

Rep: Reputation: 12
Interesting. Let's try installing Firefox NOT directly from Mozilla. Perhaps you could try this method?

Quote:
Originally Posted by mark_alfred View Post
I did notice something unusual about the addons. Beside all the active ones, I see a notation that says "ALLOWED IN PRIVATE WINDOWS" (see attached image).
That's just Firefox saying the addons will work in Private Windows. They didn't before.
 
1 members found this post helpful.
Old 05-25-2019, 10:04 AM   #6
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.6
Posts: 3,061

Rep: Reputation: 1069Reputation: 1069Reputation: 1069Reputation: 1069Reputation: 1069Reputation: 1069Reputation: 1069Reputation: 1069
Quote:
Originally Posted by Contrapak View Post
Interesting. Let's try installing Firefox NOT directly from Mozilla. Perhaps you could try this method?
My installation of 66.x that got automatically updated to 67.0 was installed directly from Mozilla with no problems at all.
I am not running debian...but I fail to see how that would matter. (I could be wrong. It has happened )
Quote:
That's just Firefox saying the addons will work in Private Windows. They didn't before.
Not exactly...before they did work in private windows and had to be manually disabled and enabled if one switched between non-private and private windows...now they can be configured by the user to work or not as they want.
 
Old 05-25-2019, 10:09 AM   #7
Contrapak
Member
 
Registered: May 2019
Location: /home/
Distribution: Arch Linux
Posts: 106

Rep: Reputation: 12
Unhappy

Quote:
Originally Posted by scasey View Post
Not exactly...before they did work in private windows and had to be manually disabled and enabled if one switched between non-private and private windows...now they can be configured by the user to work or not as they want.
I guess my "They didn't before" comment was a gross oversimplification. But I do remember none of my addons even appearing when I switched to a Private Window. Might've been from a long time ago.
 
Old 05-25-2019, 10:15 AM   #8
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.6
Posts: 3,061

Rep: Reputation: 1069Reputation: 1069Reputation: 1069Reputation: 1069Reputation: 1069Reputation: 1069Reputation: 1069Reputation: 1069
Quote:
Originally Posted by Contrapak View Post
I guess my "They didn't before" comment was a gross oversimplification. But I do remember none of my addons even appearing when I switched to a Private Window. Might've been from a long time ago.
No worries. I'm making assumptions myself. I just know that Ad-blocker worked in private windows before this release. Just before...I'm too old to remember things from a long time ago
 
1 members found this post helpful.
Old 05-25-2019, 11:12 AM   #9
Contrapak
Member
 
Registered: May 2019
Location: /home/
Distribution: Arch Linux
Posts: 106

Rep: Reputation: 12
Let's keep this thread on track.

mark_alfred, any updates?
 
Old 05-25-2019, 02:48 PM   #10
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 9, LineageOS 13
Posts: 1,454

Original Poster
Rep: Reputation: 182Reputation: 182
Well, I tried messing with the network settings, as suggested in a post above, and that didn't work. I think I'll simply try to get rid of Firefox Quantum, and go back to Firefox ESR from the Debian repository. The only reason I installed the new one was to get the Facebook Container addon, though really I don't think I need that addon (however, I quite like uMatrix, and hope to keep that going). I'm not sure how to remove Firefox Quantum, though. It's located at /usr/local/firefox, so maybe I can just remove that. Something I'll look at later (like tomorrow).
 
Old 05-25-2019, 03:05 PM   #11
Contrapak
Member
 
Registered: May 2019
Location: /home/
Distribution: Arch Linux
Posts: 106

Rep: Reputation: 12
There is a Facebook Container addon you can install. However, I'm not sure if it's strictly for Quantum. I didn't see anything on the page that said otherwise.
 
Old 05-26-2019, 08:11 AM   #12
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 9, LineageOS 13
Posts: 1,454

Original Poster
Rep: Reputation: 182Reputation: 182
Okay, I have made some progress. I restarted Firefox in Safe Mode, as suggested at the following Firefox internal site:
Code:
about:support
I got the idea to do this from here: https://support.mozilla.org/en-US/kb...refox-profiles

So, I'm now removing some of the old addons I had. I think I just had too much clutter.
 
Old 05-26-2019, 08:14 AM   #13
Contrapak
Member
 
Registered: May 2019
Location: /home/
Distribution: Arch Linux
Posts: 106

Rep: Reputation: 12
Cool. Starting from a barebones Firefox should help. It the issue originated from an addon, I wonder which one.
 
Old 05-26-2019, 08:27 AM   #14
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 9, LineageOS 13
Posts: 1,454

Original Poster
Rep: Reputation: 182Reputation: 182
Well, not from the ones I removed, apparently, since restarting Firefox in normal mode didn't work even after tossing a few of the addons. I then tried disabling all the addons and it still wouldn't work. It did work when I started it in safe mode, however. It must be something else. Well, I'll now try "Give Firefox a tune up Refresh Firefox...", since I can't figure out what to fix when it's in "safe mode".
 
Old 05-26-2019, 08:42 AM   #15
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 9, LineageOS 13
Posts: 1,454

Original Poster
Rep: Reputation: 182Reputation: 182
Hmm. So, I pressed "Refresh Firefox..." from the "about:support" page, and it refreshed everything, removing all the addons, and then it reinstalled all the addons (including those I had supposedly removed while it was in Safe Mode). So, it's working now and is back to how I had it, which, oddly, kinda creeps me out. Apparently I have a "Firefox Account", since there's a menu item on Firefox which says I have such an account (I can't recall creating it, though I must have at some point). Anyway, seems they know my exact setup. Regardless, it is now working. So, it's solved.
 
  


Reply

Tags
debian 9, firefox quantum, internet


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: The Quantum of Firefox: Why is this one unlike any other Firefox? LXer Syndicated Linux News 0 11-15-2017 07:27 AM
LXer: Introducing the New Firefox: Firefox Quantum LXer Syndicated Linux News 0 11-14-2017 03:20 PM
LXer: Start Your Engines -- Firefox Quantum Lands in Beta, Developer Edition LXer Syndicated Linux News 0 09-26-2017 10:02 AM
LXer: Firefox faster and more stable with the first big bytes of Project Quantum, simpler with compact themes and permissions redesign LXer Syndicated Linux News 0 04-20-2017 10:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration