LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-27-2006, 09:23 AM   #1
giffbd
LQ Newbie
 
Registered: Jul 2005
Distribution: SUSE 10.1
Posts: 4

Rep: Reputation: 0
Question Firefox 1.5 always loads in 'Work offline' mode


I've just installed the nice new version of SUSE (10.1) and have got my USB modem (Speedtouch 330) working with KInternet. The one silly niggle I'm having is that Firefox 1.5 always loads with 'Work Offline' toggled does anyone know how to get Firefox to automatically connect to the net when it starts up? Any help much appreciated.
 
Old 05-27-2006, 09:57 AM   #2
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,116

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
You could try putting about:config into firefox's address bar and then checking the state of the variable browser.offline

HTH
 
Old 05-27-2006, 10:03 AM   #3
giffbd
LQ Newbie
 
Registered: Jul 2005
Distribution: SUSE 10.1
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for the quick reply. "browser.offline" seems to get set to true everytime firefox is loaded - anyway to set it to false by default?
 
Old 05-27-2006, 10:42 AM   #4
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,116

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
There's something you can do (but I'm @ work and not @ linux right now!) to change it: Use common sense: try double-clicking it (the "browser.offline" entry), or R-clicking it or something until you can change it.

Last edited by tredegar; 05-27-2006 at 10:43 AM.
 
Old 05-27-2006, 11:19 AM   #5
giffbd
LQ Newbie
 
Registered: Jul 2005
Distribution: SUSE 10.1
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks tredegar... problem is that changing the value in about:config only works for that session (equivalent to toggling the work offline option in the file menu) - I notice though that when I change the browser.offline value from true to false, the status switches from 'default' to 'user set'. So I still wonder if there's a way to change the default?

It's annoying but it's not a critical problem at the end of the day I'm still very happy with SUSE 10.1 overall and have found a firefox extension which provides a work offline toggle button (https://addons.mozilla.org/firefox/493/)
 
Old 05-28-2006, 02:15 AM   #6
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,116

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
OK, I tried it:
I do not have a setting for browser.offline (Firefox 1.0.2), but my other settings I can change by R-clicking them and choosing "Modify". The value now becomes "User Set" and I can set it as I like. These settings persist between restarts of Firefox.
R-Clicking a value also allows me to choose "Reset", in which case the value is set to the default value, and this is reflected in the "status" column, which now shows "default". You can of course also "user set" the variable to the default value, and this will then be refected in the status column, which will show "default".
I also notice that if I select "File-Work Offline" and then close FFox, next time I open it, it will still be set to "Work Offline". The same applies if I uncheck "File-Work Offline" - this persists between restarts.
This behaviour seems quite logical to me!
Anyway, you seen to have fixed your peoblem with an extension.
 
Old 12-13-2010, 07:57 PM   #7
arunvv
LQ Newbie
 
Registered: Feb 2004
Posts: 9

Rep: Reputation: 0
about :config in firefox and

toolkit.networkmanager.disable; true
browser.offline; false

will solve the problem.

No need for any add-ons.
 
Old 12-13-2010, 08:13 PM   #8
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,363

Rep: Reputation: 172Reputation: 172
arunvv

Before you post to a thread look at the date of the last post in the thread. This thread was over four years since the last post. A good rule of thumb is , if it is a year or more since the last post, skip it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Work Offline always activated on Firefox startup shooters Linux - General 7 09-23-2006 04:24 PM
Firefox loads 10x faster in Windows... why? hisnumber666 Linux - Software 5 05-02-2006 10:17 AM
Firefox Loads Pages SLow shof515 Linux - Newbie 8 01-14-2006 12:23 AM
Dirty "RAID"-array in linear mode after hdd went offline tomas412 Linux - Software 1 08-14-2004 10:12 AM
Mandrake Linux - IPW2100 - loads but doesn't work rieger Linux - Wireless Networking 5 08-10-2004 11:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration