LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Firefox 0.9.3 fails to start on Fedora Core 2 (https://www.linuxquestions.org/questions/linux-software-2/firefox-0-9-3-fails-to-start-on-fedora-core-2-a-218443/)

damion 08-16-2004 05:29 PM

Firefox 0.9.3 fails to start on Fedora Core 2
 
I've just downloaded the Firefox 0.9.3 installer and installed it (as root) to /opt/firefox-0.9.3. If I try and run the new installation ($ /opt/firefox-0.9.3/firefox) I get nothing (no error message), unless Firefox 0.9.1 is currently running (or I use the -ProfileManager switch), then the Profile Manager starts.

I get the same results, as root or my normal user account. If I try the -display=0 switch, I get the error message "gtk+ could not open display 0"

I have the following configuration:
Fedora Core 2
kernel 2.6.7-1.494.2.2
gtk+ 1.2.10-29.1.1
glibc 2.3.3-27

However, I don't (appear) to have XFree86 installed (?!). $ rpm -qf `which X` tells me that X is provided by the xorg-x11-6.7.0-5 package.

I'm very confused. Does anyone have any ideas? :confused:

Edited to add: I forgot to mention that Firefox 0.9.1 works fine on this system (installed to /opt/firefox-0.9.1)

damion 08-21-2004 05:36 AM

Sorted it. I ran /opt/firefox-0.9.3/firefox as root and now it works for everyone. I thought I'd done that already! :newbie:


All times are GMT -5. The time now is 11:24 PM.