LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-04-2005, 03:39 PM   #1
BeNoMiS
LQ Newbie
 
Registered: Nov 2003
Posts: 7

Rep: Reputation: 0
filenames on cdrom or images are cutted


Hello there,

Since a few day's I walk agains a strange problem.
When I mount a cdrom or an image from a cdrom the contents are cutted off to 8 signs

f.e. netopyr@Dukla ~ $ ls /mnt/cdrom/movies/
humaned.mpq nighte~1.mpq tutori~1.mpq undeaded.mpq
humanop.mpq orced.mpq tutori~2.mpq

I have totaly no idea how it becomes like this or how to change it back so I can install any games again on my computer. (now installers complains about missing files because they are cutted off).

does anyone have any idea?

regards

Code:
netopyr@Dukla ~ $ uname -a
Linux Dukla 2.6.10-gentoo-r1 #4 SMP Fri Jan 21 14:44:46 CET 2005 x86_64 AMD Athlon(tm) 64 Processor 3400+ AuthenticAMD GNU/Linux
 
Old 02-04-2005, 03:58 PM   #2
Calestar
LQ Newbie
 
Registered: Dec 2004
Location: Sorel-Tracy, Quebec,Canada
Distribution: Fedora
Posts: 8

Rep: Reputation: 0
It might have something to do with the CDROM file system used ... you might want to look at that
 
Old 02-04-2005, 04:05 PM   #3
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
you forgot to enable it in your kernel config

go to file systems->cd/dvd filesystems and make sure microsoft joliet extensions is set.
 
Old 02-04-2005, 04:06 PM   #4
BeNoMiS
LQ Newbie
 
Registered: Nov 2003
Posts: 7

Original Poster
Rep: Reputation: 0
I was thinking about that also but the cdroms are just iso9660...
 
Old 02-04-2005, 04:11 PM   #5
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
if they use vfat as the filesystem you will need the extensions.

this is why they are being displayed as they are ( in DOS filenames longer than 8 characters are truncated and a tilde is used).

check and make sure you compiled support for vfat and the extensions

Last edited by __J; 02-04-2005 at 04:13 PM.
 
Old 02-04-2005, 05:02 PM   #6
Valhalla
Member
 
Registered: Nov 2004
Location: Atlanta
Distribution: Gentoo 2005.1, Ubuntu 5.10
Posts: 267

Rep: Reputation: 30
It might help if you try setting the filesystem when you mount the cdrom to auto. It will work if you have microsoft joilette extensions compiled into your kernel
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Notification sounds are cutted djortz SUSE / openSUSE 2 11-29-2005 05:27 AM
Convert cd images to dvd images rcsuk Debian 2 07-11-2005 10:34 AM
mount cdrom - filenames lenght cutting drenal Linux - Newbie 3 12-27-2003 08:50 AM
/dev/hda1 does not appear to contain redhat cdrom images JMO8 Linux - Newbie 2 11-24-2003 07:29 AM
new compiled Kernel but CDROM filenames changed fbarre Linux - Newbie 3 08-29-2003 07:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration