-   Linux - Software (
-   -   File icons in nautilus not showing with xfce4 (

mtvoid 04-17-2004 10:35 AM

File icons in nautilus not showing with xfce4
I've set up xfce4 on my laptop and would like to use it as the default. The only thing that I miss is a usable file manager. I like the new nautilus with gnome 2.6 and so I tried starting that up in XFCE. It works fine, but there's a problem with it rendering the file icons. For all files and directories, I see the standard file icon (which looks more like the one from gnome 1.2). For image files, I do see the thumbnails, and the 'Start Here' link on the desktop also shows a proper icon, but none of the other icons are picked up from my chosen icon theme (which I can set from 'theme preferences' withing gnome). Nautilus, while running in gnome shows no problems otherwise. Could anybody help me figure out how to make nautilus show the proper icons for all files when running under xfce? For those of you who do use nautilus in xfce4 themselves, do you have any icon troubles? Anyway, I would appreciate any help with this.

I'm running debian sid, xfce 4.03, and gnome 2.6 from experimental.

vinay_s_s 04-17-2004 12:50 PM

well this is what i did on my slack 9.1 for gnome-2.6:

backed-up /usr/share/icons/hicolor and deleted it from /usr/share/icons

copied /usr/share/icons/gnome to /usr/share/hicolor

NOTE: this is a very ugly solution. kids.. please dont try this at home ;-)

mtvoid 04-17-2004 02:46 PM

Oh well, it works, but now the icons back in gnome get messed up :( . Anyway, the xfce developers are aware of this, so I'll just be patient and wait for the next version to fix this. Or maybe till then, I can put in a little script for both the xfce and gnome sessions to link to the proper icon dir while starting up...

vinay_s_s 04-18-2004 12:01 AM

The problem i think is not of xfce or anything but of GNOME itself. I was having this problem in any environment other than gnome.

try to solve the gnome issue by selecting the icons (in gnome-theme-manager) as hicolor

apeekaboo 08-18-2004 06:46 AM

Yay! This solved my problem as well! :)

After upgrading nautilus on my system where I run fluxbox, I had the exact same problem as mtvoid had.

cd /usr/share/icons/
mv hicolor/ hicolor.old
ln -s Gorilla/ hicolor

Sym-linking is not as permanently as deleting the the old icons.
Gorilla is the scalable Gorilla theme over at .

All times are GMT -5. The time now is 06:36 PM.