-   Linux - Software (
-   -   fglrx driver error: failed to initlialize APIC in kernel (

verdeboy2k 05-26-2006 03:41 PM

fglrx driver error: failed to initlialize ASIC in kernel [Solved]
I recently installed the 8.25.18 ATI driver for my Radeon x1800 card sucessfully. I however, was using Xorg 6.8, and since I wanted to use Xvideo, I attempted to upgrade to Xorg 7.0, which failed to work. I reinstalled 6.8, which worked fine with the VESA drivers, but when I tried to use the fglrx driver again I get this error:

[EE][fglrx] Failed to initialize ASIC in kernel.
and various unresolved symbols in fglrx_drv.o which I can't remember, posting this in Windows boot of same box.
Caught signal 11, aborting...

I have removed every trace of fglrx, Xorg, and all the config files, reinstalled from scratch, and it still doesn't work. Is there anything that I might have broken that I can't find?

EDIT: dmesg reported no errors, just the sucessful loading and unloading of fglrx.ko
System Specs:
Linux 2.6.16-gentoo-r7 (custom)
AMD Athlon 64 x2 2.4Ghz
ATI Radeon x1800 xt 512MB (PCI-X)
LanParty UT nF4 Ultra-D
SoundBlaster Audigy 2 ZS

verdeboy2k 05-27-2006 07:36 AM

UPDATE: After more tries to get this working, X will not start at all, even from a fresh install unless its run as root.

verdeboy2k 05-27-2006 06:47 PM

Finally got X11R7 to install, so no longer an issue

All times are GMT -5. The time now is 03:31 PM.