-   Linux - Software (
-   -   ffmpeg records black when recording a 3d game. (

kev717 09-16-2011 07:14 PM

ffmpeg records black when recording a 3d game.
I'm using Sabayon Linux and trying to screencast me playing a video game (postal2). I am using ffmpeg and x11grab, however whenever I open the game, the only thing x11grab gets is a black screen. Anyone have any ideas how to fix this? The following is the command I used. (huffYUV doesn't seem to do anything to help me).

ffmpeg -f x11grab -i :0.0 -r 25 -vcodec huffyuv -sameq -threads 2 screne.avi
I also tried:

ffmpeg -f x11grab -i :0.0 -vcodec huffyuv -sameq -threads 2 screne.avi

My desktop uses XFree86. I record the audio using a separate ffmpeg command and using alsa.

This also fails using gtk-recordmydesktop (which has never worked for me).

Any ideas how to fix this?

H_TeXMeX_H 09-17-2011 05:03 AM

Here's the command I used to capture screencasts:


ffmpeg -f x11grab -s 854x480 -r 25 -i :0.0+400,280 -vcodec libx264 -vpre hq -crf 15 -s 854x480 -aspect 854:480 -r 25 -threads 4 -y tmp.mkv
Adjust as necessary.

frieza 09-17-2011 07:59 AM

i would imagine it would be difficult to record anything that uses direct rendering, it probably bypasses whatever layer that ffmpeg or other screen recorder uses.

difficult mind you, not impossible, it has been done i'm sure, but i would start on finding tutorials on how to record video from programs that use direct rendering.

H_TeXMeX_H 09-17-2011 11:23 AM

I was able to record from minecraft with that command ... not sure if that uses direct rendering or not. I think it might, and it is 3D.

All times are GMT -5. The time now is 10:45 PM.