LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-22-2016, 07:42 AM   #1
Nick_C
Member
 
Registered: Jan 2012
Location: London, England, UK
Distribution: CentOS 6, CentOS 7
Posts: 297

Rep: Reputation: Disabled
ffmpeg-libs-2.6.8-3.el6.nux.x86_64 needs libavcodec.so.53


Trying to update ffmpeg to: ffmpeg-libs-2.6.8-3.el6.nux.x86_64

However this fails with:
Code:
Gstreamer-vaapi-0.2.12-3.el6.nux.x86_64 requires libavcodec.so.53(LIBVACODEC_53)(64-bit)
Where do I get libavcodec.so.53 from?

Thanks,
 
Old 05-22-2016, 09:14 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,393

Rep: Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607
`ffmpeg-libs-2.6.8-3.el6.nux.x86_64' is from the "nux repo".

The package `ffmpeg-libs' from "nux" will provide /usr/lib64/libavcodec.so.53

Overview https://www.salstar.sk/rpmbrowse/find?repo=nux-dextop

EL6 repo http://li.nux.ro/download/nux/dextop...nux.noarch.rpm


-
 
Old 05-22-2016, 01:05 PM   #3
Nick_C
Member
 
Registered: Jan 2012
Location: London, England, UK
Distribution: CentOS 6, CentOS 7
Posts: 297

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by knudfl View Post
`ffmpeg-libs-2.6.8-3.el6.nux.x86_64' is from the "nux repo".

The package `ffmpeg-libs' from "nux" will provide /usr/lib64/libavcodec.so.53
-
Unfortunately it doesn't, when I try to install ffmpeg-libs it throws the libavcodec error.
 
Old 05-22-2016, 02:54 PM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,393

Rep: Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607Reputation: 3607
Sorry, seems I looked into the wrong package.

`ffmpeg-libs-2.6.8-3.el6.nux' provides /usr/lib64/libavcodec.so.56 .

Which command are you using to update ffmpeg-libs ?
# yum install ffmpeg-libs
... should update all other packages depending on libavcodec.so.xx, etc.

? Are you sure you have installed the latest nux = nux-dextop-release-0-2.el6.nux.noarch.rpm
http://li.nux.ro/download/nux/dextop...nux.noarch.rpm
.. Download the package and :
# cd Downloads/ && yum install nux-dextop-release-0-2.el6.nux.noarch.rpm


-
 
Old 05-22-2016, 03:18 PM   #5
Nick_C
Member
 
Registered: Jan 2012
Location: London, England, UK
Distribution: CentOS 6, CentOS 7
Posts: 297

Original Poster
Rep: Reputation: Disabled
Quote:
Which command are you using to update ffmpeg-libs ?
# yum install ffmpeg-libs
... should update all other packages depending on libavcodec.so.xx, etc.
Yep, exactly that.

Quote:
? Are you sure you have installed the latest nux = nux-dextop-release-0-2.el6.nux.noarch.rpm
http://li.nux.ro/download/nux/dextop...nux.noarch.rpm
Yep, already on correct nux repo.

It seems the problem was with Gstreamer-vaapi being installed, removed that and ffmpeg-libs then installed fine.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gcc-4.4.6-4.el6.i686 conflicts with file from package gcc-4.4.6-4.el6.x86_64 linuxandtsm Linux - Newbie 1 03-26-2013 02:19 PM
libavcodec misscompiled warning in ffmpeg dive Linux - Software 2 12-13-2006 06:00 PM
Transcode and FFMpeg(libavcodec) issues PTG Linux - Software 2 04-08-2006 09:37 PM
decoder and encoder with ffmpeg (libavcodec) sangijuela Programming 1 08-20-2005 08:53 AM
ffmpeg - libavcodec & libavformat james_vasant Programming 1 08-16-2005 01:43 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration