-   Linux - Software (
-   -   FF 2.0 spell checker ??? (

lleb 01-31-2007 07:46 AM

FF 2.0 spell checker ???
how do you get it to work under linux? in both OSx and Linux (debian etch) the spell checker in FF 2.0 will place the red line under the misspelled word, but when you right click, you get no OPTION to pick the correct word?

under windows if you misspell a word, you get the red line under it, then when you right click you can pick from a list of words that are close to what you are trying to spell and it will change it for you much like in OOo or MS Word.

how do you get this behavior in Linux?

camorri 01-31-2007 09:10 AM

Under Edit-->Preferences-->Advanced-->General-->Browsing--> put an 'x' in the box "Check my spelling as i type"

Also check your setting for for spellchecker.dictionary. In the URL bar type about:config and type 'spellchecker.dictionary' in th efilter field. You shoud see the in the value field the dictionary to use.

lleb 01-31-2007 09:43 AM

ok thanks. ill look for that when i get home.

lleb 01-31-2007 09:45 AM

just FYI, under OSx the check my spelling is there as is the proper dictionary. still no chance to right click and get a list of words to replaced the misspelled word.

lleb 01-31-2007 01:57 PM

ok tried that still nothing.

camorri 01-31-2007 06:07 PM

Have you got spell checking configured in your desktop settings?

In KDE it is configured in the Control Center.

lleb 01-31-2007 06:41 PM

no clue, how do i do that?

camorri 01-31-2007 07:01 PM

Click on the "start button" and look for Preferences. Then there is an entry for Control Center, click it. Once the Control Center opens, click Components and Spell Check. There are a few things to fill in form drop downs. I'm using the Aspell client. You may need to install it if it is not on your system.

lleb 02-03-2007 02:01 AM

buggerz, still not working. did as you stated in the control center yes it is there, yes it is active and switched to aspell from ispell and still no good.

camorri 02-03-2007 06:28 AM

Hmmm, I don't understand either at this point. Sorry I can 't be of more help. I can only guess this may have something to do with Etch, it works on my systems, Mandriva 2006 and Xubuntu 6.06. Hopefully someone else can help.

lleb 02-03-2007 09:35 AM

well it does not work on my kids edubuntu, it does not work in OSx and it does not work on my computer. the only time i have ever seen the spell checker provide replacement words is under windows.

yes the linux and OSx vs both underline the misspelled words in red, but that is all i get. when i right click all i get is the following options:

(check mark)spellcheck this field

no list of words to replace the bad word.

PTrenholme 02-03-2007 09:45 AM

Try installing the "MR Tech" local install extension. Then you can export the settings from the systems where it works and import them to your non-working one. (Or export both systems settings and do a diff on the XML to see what's different.)

Also, search for "dictionary" in the FF extensions. Perhaps installing one of those dictionaries might fix your problem.

Another thought: Have you installed OpenOffice? If so, does the spelling checker work in the "Word Processor" OO application?

All times are GMT -5. The time now is 03:24 PM.