LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Fedora Core 6 internet stuffs up after update. (https://www.linuxquestions.org/questions/linux-software-2/fedora-core-6-internet-stuffs-up-after-update-496756/)

Chuong 10-29-2006 08:22 PM

Fedora Core 6 internet stuffs up after update.
 
Hello again guys.

Just a problem that resulted after I updated my Fedora Core 6.

OK, this is what happened:

1) I formatted my computer and installed Fedora Core 6 fresh.

2) After installation, Fedora Core now has a package updater which told me there were 23 packages to update.

3) I clicked on it and it asked for the root password.

4) I entered the root password and then some updater window comes up, saying resolving dependencies and such.

5) After resolving dependencies, a button called "apply updates" appeared.

6) I updated clicked on it and it updated everything such as SELinux policy, new totem browser plugin etc and a lot of other packages I can't remember.

7) Then I rebooted my computer and then tried the internet again.



After updating my packages, I can no longer use the Internet such as mozilla browser, or GAIM internet chatting program.

I know my network is connected and worked fine since I can connect to my other computer's network and access folders and files.

I believe one of the new SELinux packages stuffed up my Internet or something.

Also when I tried to use Yum (the GUI Yum), there was an error message saying something about not being able to open yumrepo.xml or something in the yum.d.repos directory.

I'm using Fedora Core 6, 2.6.18-1.2798 i686.

Any help would be much appreciated, thank you in advance,




Chuong.

Chuong 10-30-2006 05:10 AM

Please guys, any help would be great.

Life without the Internet on my Fedora Core 6 feels so harsh :cry:

This yum update packages are stuffing up my computer.

I can't even use yum now.

This is what happens when I try to use yum:

Cannot open/read repomd.xml for repository: livna

and other error messages in the YumEx window:

Cannot find a valid baseurl for repor: core
Cannot find a valid baseurl for repor: updates
Cannot find a valid baseurl for repor: extras


:scratch:

- None of my Internet stuff are working either.
- My yum doesn't work.
- My RPM commands don't work.

I'm going crazy!!!


Anyone say something!?

Have you had this problem before and did you fix it?

Do you know what I'm talking about?

Lsatenstein 10-31-2006 05:53 PM

Hi Chuong

From what you indicated, you have created a package conflict by leaving livna enabled. Not all livna updates are core6 compatible. In fact, once you download a critical software item with a seamingly livna equivalent, you are probably locked out from what you want to do.

So, do the following

rpm -qa * | less
search through the list and take note of the livna stuff.
Use livna only for multimedia, and do not use it for anything else.

Or reinstall by ensuring the livna repository is not in your initial updates.

Chuong 10-31-2006 09:11 PM

I can't use RPM commands Lsatenstein.

Yes, I'm the user "su -" but I still can't use RPM commands.

Anyhow when I tried to use command:

rpm -qa * | less

The page just turn white with nothing except " ~ " going down the left side of the shell prompt.

No message or anything, just " ~ " and " " (white spaces).

By the way

I tried to disable the livna repository and tried doing yum install [something] and it just say:

cannot find valid baseurl for repo: core

I checked the repo folders for core, extras and updates. I found them but there were nothing inside them.

Chuong 11-01-2006 08:34 AM

Hey guys, my INternet problem is solved now!

Thanks to Leigh for his relentless support, after a mad 69 continuous post:

http://forums.fedoraforum.org/showth...624#post664624


All times are GMT -5. The time now is 11:24 AM.