LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-17-2006, 05:21 PM   #1
dude998866
Member
 
Registered: Dec 2005
Posts: 94

Rep: Reputation: 15
Fedora Core 5 XMMS


Heres the problem, when I double click and mp3 file to play it XMMS opens but refuses to switch to the song and start playinf automaticly. It just opens to the last song played and just sits there. I have to manually open the songs to play them. How do I make it do this automaticly, I've never had this problem with any other version of linux so I'm stumped.. thanx
 
Old 04-17-2006, 11:06 PM   #2
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
I personally don't use xmms because realplayer and mplayer and totem play everything better - totem, with a nice visualisation.

Do you have this trouble only for mp3? (Try other formats - you should be using ogg/vorbis anyway). How did you install xmms and the mp3 plugin?
 
Old 04-17-2006, 11:35 PM   #3
dude998866
Member
 
Registered: Dec 2005
Posts: 94

Original Poster
Rep: Reputation: 15
XMMS was istalled via YUM and the plugin was istalled via a Mad-lib package
 
Old 04-18-2006, 12:18 AM   #4
daihard
Member
 
Registered: Jul 2003
Location: Seattle, WA
Distribution: Kubuntu 14.04 LTS
Posts: 915

Rep: Reputation: 34
Quote:
Originally Posted by dude998866
XMMS was istalled via YUM and the plugin was istalled via a Mad-lib package
As far as Fedora Core is concerned, just double-clicking an MP3 file (assuming you set the file association correctly so it invokes xmms) will not start XMMS automatically. Here is what you need to do. Go to the menu shortcut that defines the way XMMS starts. I bet the command edit box says: "xmms -e %F" where %F is replaced by the song you double-click. Change it to "xmms -p -e %F" and save it. Next time you double-click on a song, XMMS should start playing it automatically. If you do want to clear the previous playlist as you double-click a new song, remove "-e".
 
Old 04-20-2006, 12:39 AM   #5
match002001
LQ Newbie
 
Registered: Mar 2006
Posts: 3

Rep: Reputation: 0
OKay what if you can't even add a file to XMMS. Every time I add an .ogg file it will act like it did it but it won't show up much less play it.

any clue?
 
Old 04-20-2006, 03:13 AM   #6
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Lets get this right: you start xmms so the interface is on the desktop - you drag a ogg/vorbis file to the xmms interface and drop it... and xmms does... nothing?

You run xmms from commandline and ... ?

The following is from www.mjmwired.net (FC5 installation notes)
Quote:
Run xmms through the menu or by running 'xmms' at the shell.
And go to the XMMS Options:

Options > Preferences >

Audio I/O Plugins > Input Plugins

Disable: MPEG Layer 1/2/3 Placeholder Plugin [librh_mp3.so]
==> UNCHECK [ ] Enable Plugin

Audio I/O Plugins > Output Plugin

SET: ALSA 1.2.10 ouput plugin [libALSA.so]

General Plugins

Enable: Status Docklet Plugin 1.0 [libstatusdocklet.so]
==> Check [ ] Enable Plugin
Apply
 
Old 04-20-2006, 03:19 AM   #7
daihard
Member
 
Registered: Jul 2003
Location: Seattle, WA
Distribution: Kubuntu 14.04 LTS
Posts: 915

Rep: Reputation: 34
Quote:
Originally Posted by Simon Bridge
Lets get this right: you start xmms so the interface is on the desktop - you drag a ogg/vorbis file to the xmms interface and drop it... and xmms does... nothing?

You run xmms from commandline and ... ?

The following is from www.mjmwired.net (FC5 installation notes)
Just curious, why do you want to disable the placeholder plugin?

For ogg file playback, you must have the "Ogg Vorbis Player" plugin included with XMMS. It should come standard with the XMMS installation, though.
 
Old 04-20-2006, 03:41 AM   #8
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
Just curious, why do you want to disable the placeholder plugin?
I don't use xmms - not since RH9 - don't see the point. This advice was from Mauriat Miranda - at a guess I'd say it was so he could play mp3 files as well ... using the mp3 plugin that the placeholder claims to be for. But this is just a guess.

Personally, I use totem gstreamer for all but dvds... and rythmbox seems pretty nifty. Both come with FC4 wot I have. Won't be upgrading till FC6. (Mind you, saw a recent xmms in DSL last month, was that video I saw there? I may be lured back...)
 
Old 04-20-2006, 03:48 AM   #9
daihard
Member
 
Registered: Jul 2003
Location: Seattle, WA
Distribution: Kubuntu 14.04 LTS
Posts: 915

Rep: Reputation: 34
Quote:
Originally Posted by Simon Bridge
Personally, I use totem gstreamer for all but dvds... and rythmbox seems pretty nifty. Both come with FC4 wot I have. Won't be upgrading till FC6. (Mind you, saw a recent xmms in DSL last month, was that video I saw there? I may be lured back...)
I hear ya. The only reason I still have XMMS around is that it plays (unlocked) AAC files. For all the other music files I use JuK. Did you see some sneak preview of a new version of XMMS? Does it look promising?
 
Old 04-20-2006, 04:05 AM   #10
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
I'm not sure - it was only a glimps on the latest Damn Small Linux CD... which is on loan right now. Looking at: http://memory.xmms.org/xmms_v1.2/doc...section-1.12-1
... no mention of anything like this is made. OTOH: they don't mention ogg/vorbis support either.

The DSL homepage is similarily mute - I recall it had the usual black xmms panel, with a square screen under it playing goom with the music. Of course, I could be going senile... when I was using xmms, I had mplayer skinned to match
 
Old 04-20-2006, 09:38 AM   #11
Chuong
Member
 
Registered: Apr 2006
Posts: 161

Rep: Reputation: 30
Totem movie player doesn't play anything for me. I tried to play an mp3 file, but Totem movie player says I don't have the codecs to play it.

Real player can play it though.

Totem movie player can't play my .avi files, too.

Any ideas how I can fix this?



Chuong.
 
Old 04-20-2006, 06:32 PM   #12
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
I have totem gstreamer playing everything - You need to install all the other gstreamer packages (available via yum) ... I used yumex and searched for anything "gstreamer" so I'll be pressed to issue exact yum repo and commands. I suspect you'll need livna.

Anyway:- the packets are (yum install <packet>)
gstreamer (you have this with totem)
gstreamer-ffmpeg
gstreamer-plugins

Interestingly, the first time I did this, I got all the win formats playing by installing the mplayer mscodecs package.

Generally, you need the fedorafaq for FC5 - is it there yet? It's usually a little late. As well, you want to look slowly through the "resources > FC5 install notes" in www.mjmwired.net... not kidding: look through that before attempting anything else - especially if you are new to linux/fedora.
 
Old 04-20-2006, 11:10 PM   #13
daihard
Member
 
Registered: Jul 2003
Location: Seattle, WA
Distribution: Kubuntu 14.04 LTS
Posts: 915

Rep: Reputation: 34
Quote:
Originally Posted by Simon Bridge
Generally, you need the fedorafaq for FC5 - is it there yet? It's usually a little late. As well, you want to look slowly through the "resources > FC5 install notes" in www.mjmwired.net... not kidding: look through that before attempting anything else - especially if you are new to linux/fedora.
I've been waiting for it, too. Most of the information available for FC4 is applicable to FC5 as well, but there are fine prints that differ.
 
Old 04-21-2006, 04:43 AM   #14
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
That's why I've included the mjm site.

chuong and dude? Do respond - tain't polite to keep the hackers sans feedback. You're supposed to tell us what cool dudes we are And edit your profile to show your distro and location... thanx.
 
Old 04-22-2006, 04:32 AM   #15
Chuong
Member
 
Registered: Apr 2006
Posts: 161

Rep: Reputation: 30
Huh?

Wha?

What hacker sans?

I'm using the Fedora Core 4.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot install xmms on fedora core 4 crnac Linux - Software 2 07-18-2005 10:20 AM
unable to use xmms and xine on Fedora core 3 manishbendre Linux - Newbie 4 03-30-2005 02:42 PM
Fedora Core 3 - No sound XMMS MTUTech Linux - Newbie 35 01-29-2005 11:36 PM
In Fedora Core 3 only in XMMS no sound Hades Linux - Newbie 6 01-19-2005 04:32 AM
XMMS-AAC Not Installing (Fedora Core 3) Kenji Miyamoto Linux - Software 0 01-02-2005 05:42 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration