-   Linux - Software (
-   -   Fedora 9:No mysql.sock file found. Cannot start mysql (

smilingbuddha 09-09-2008 06:15 AM

Fedora 9:No mysql.sock file found. Cannot start mysql
I installed mysql using rpm package in my Fedora 9. Though the installation did not point out to any errors when i tried to start mysql using mysqld_safe the server starts and then shuts down immediately automatically. When I try to access mysql I got the error that it could not connect to local server through /var/lib/mysql/mysql.sock. I think that this is because I hadn't started the server yet. But how do I start it? mysqladmin and mysqld_safe do not work.
The settings in my.cnf are correct and the path for socket is /var/lib/mysql/mysql.sock. But no such file is found. I have no mysql.sock in /tmp either.
I have disabled selinux if that would have been a problem. Can anyone help me out please.

paulsm4 09-10-2008 12:32 AM

Hi -

The reason you're getting "mysqld.sock not found" is because you haven't started the MySQL Server.

The best way to test-start is:

/etc/init.d/mysqld start
Once you're sure everything is working, then configure MySQL to start automatically when the system boots. I'm not sure what tools Fedora provides to configure your runlevel (there's probably some kind of "Control Panel" GUI), but you can always use the command-line "chkconfig".

'Hope that helps .. PSM

smilingbuddha 09-14-2008 09:17 AM

Thanks.. So i hadn't started the server at all.. It works now

tarundas 03-21-2009 03:06 AM

Thanks a lot
Thanks a lot paulsm4 ...the best and appropriate answer I found in internet for 'mysql.sock not found' problem ...I have been struggling to solve this problem since last two days. Thanks again.

All times are GMT -5. The time now is 05:17 PM.