LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-19-2003, 11:00 PM   #1
hobylinux
Member
 
Registered: Jul 2003
Location: Ohio, USA
Distribution: Mandrake 9.2
Posts: 145

Rep: Reputation: 15
fcitx problems


hey, all. i've got a few problems with fcitx that i was hoping to get some help with. i installed the noarch rpm (version 1.8.5) and edited my /etc/sysconfig/i18n file according to the instructions. i bumped into three problems, though:

1. all english characters are excessively large, and it looks really bad. any way to change this?
2. when i'm using the pinyin input method (the only one i've tried as it's the only one i know how to use) i can't see any of the characters in the input window. when i hit space they appear in the program i'm using, and if i hit different numbers different characters appear (you know, you type in "zhao" and it will give you a bunch of choices, 1 being a different character from 2, and so on). it's kind of useless as an imput method without this ability.
3. i would like to figure out a way to use fcitx to type in chinese while still being an english user. if that's not possible, though, i'm willing to operate in a totally chinese environment.

thanks for any suggestions anyone may have.

Last edited by hobylinux; 11-20-2003 at 07:59 PM.
 
Old 11-20-2003, 10:14 PM   #2
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Mineral, Virginia
Distribution: Debian 8
Posts: 7,893

Rep: Reputation: 339Reputation: 339Reputation: 339Reputation: 339
" i would like to figure out a way to use fcitx to type in chinese while still being an english user."

I don't know the answer to your question but I can refer you to someone who does. chinaman is an American living in China and he probably knows the answers to your questions. You can probably contact chinaman by clicking on the members button, whenever the members button starts working again.


___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
Old 11-23-2003, 12:59 PM   #3
hobylinux
Member
 
Registered: Jul 2003
Location: Ohio, USA
Distribution: Mandrake 9.2
Posts: 145

Original Poster
Rep: Reputation: 15
thanks for the suggestion. when the button starts working again, i'll try to get in touch with him. in the meantime, anyone else have any ideas?

thanks a lot.
 
Old 11-23-2003, 02:05 PM   #4
codec
Member
 
Registered: Sep 2003
Location: mad.es.eu
Distribution: ubuntu 5.04 knoppix Slack91/10 freebsd51 vector4 redhat9
Posts: 304

Rep: Reputation: 30
LC_CTYPE define which language type/code do you use for input. LC_MESSAGES define the message dialogs language/code that you like. If you set LC_MESSAGES to en_US most dialog would become English, you can also set LANG to english.

I also use UIM & wenju to use windows-like unicode input method in gtk applications. wenju isn't very well developed yet.
 
Old 11-23-2003, 02:55 PM   #5
hobylinux
Member
 
Registered: Jul 2003
Location: Ohio, USA
Distribution: Mandrake 9.2
Posts: 145

Original Poster
Rep: Reputation: 15
yeah, unfortunately i've tried that, and it's the LC_CTYPE setting that messes up the fonts. here's what it's doing, from what i can figure: any program whose fonts are decided by kde's configuration utility are defaulting to sans, which looks horrible when the LC_TYPE is set to zh_CN. this includes all gnome apps, mandrake's control center, terminal, and some other stuff. changing the gnome fonts (by logging into gnome and using its configuration utility) makes all the gnome apps look fine in gnome, but they still use sans in kde. aaaaargh
 
Old 11-23-2003, 03:25 PM   #6
codec
Member
 
Registered: Sep 2003
Location: mad.es.eu
Distribution: ubuntu 5.04 knoppix Slack91/10 freebsd51 vector4 redhat9
Posts: 304

Rep: Reputation: 30
maybe it's fonts and hinting problems. My fonts in my redhat shell is bad but np in freebsd. but you will use Mandrake, so let's try this "wenju"

it's a gtk input method which would work in gaim/xchat/gedit....etc but I don't know if there are any way to make it work in mozilla or other browser.

after the install, you may need to type:
gtk-query-immodules-2.0 > /usr/X11R6/etc/gtk-2.0/gtk.immodules

and edit the files so no uneeded input methods wouldn't block the screen.

Last edited by codec; 11-23-2003 at 03:45 PM.
 
Old 11-24-2003, 09:05 PM   #7
JDW
Member
 
Registered: Feb 2003
Location: Melbourne, Australia
Distribution: Ubuntu 6.10, Slackware 11.0
Posts: 192

Rep: Reputation: 30
"3. i would like to figure out a way to use fcitx to type in chinese while still being an english user. if that's not possible, though, i'm willing to operate in a totally chinese environment."

To hobylinux, I use fcitx in KDE / Mandrake 9.2 while logged in an English environment...though you have to side-step around the problem.

it's quite easy really, you create a "Chinese" user (for the purpose of running applications on their own with Chinese settings & input) and edit the /home/chinese_user_name/.bashrc file by adding the following lines :-

export LANG = zh_CN
export LC_ALL = zh_CN
export LC_CTYPE = zh_CN
export XMODIFIERS = @im = fcitx


This will set the locale environment for his user to simplified Chinese based on the GB2312 coding system...

Then, while you are logged in your normal English environment, run an app in which you wish to type in Chinese (e.g. OO Writer or Evolution etc.) from a terminal window (e.g. Konsole) as follows :-

$ su chinese_user_name // (this logs you in THAT terminal as a Chinese user)
enter password :

$ fcitx & oowriter

Bingo! this instance of oowriter will have Chinese menus etc. and you can type using fcitx/pinyin - and you're still logged in as your English user!

good luck,

JDW
 
Old 11-25-2003, 09:44 AM   #8
hobylinux
Member
 
Registered: Jul 2003
Location: Ohio, USA
Distribution: Mandrake 9.2
Posts: 145

Original Poster
Rep: Reputation: 15
thanks JDW!

thanks for the reply, JDW. that works great! if you don't mind, i have a few more questions for you (or anyone else who uses fcitx). do you have any problem with the ime window not showing the characters? i installed from the rpm on fcitx's website. secondly, i've discovered that i can't type any emails in chinese, or even forward chinese emails i get from other people. the encoding gets all screwed up and comes out as a bunch of random characters. any insight on this? finally, i can't view any documents in chinese in openoffice.org 1.1, even though i'm opening it with the chinese settings (i'm actually at the moment doing most of my stuff logged in as the chinese user, until i get it all figured out, and then i'll start opening specific programs with my chinese user's settings, like JDW said how to do).

thanks again.

hobylinux
 
Old 11-25-2003, 03:47 PM   #9
JDW
Member
 
Registered: Feb 2003
Location: Melbourne, Australia
Distribution: Ubuntu 6.10, Slackware 11.0
Posts: 192

Rep: Reputation: 30
fcitx problems

hi hobylinux,

I ain't no expert in Linux, but I suspect that when you installed Mandrake maybe not all the Chinese font and locale files were installed...I could be wrong though!

When you load up the Mandrake CD to install, the first options screen asks you what your install language will be, which we always choose English I guess, but at the bottom of that screen is an Advanced button, if you click on that you can select Simplified and/or Traditional Chinese as additional languages. Selecting these will tell the MDK installer to install all the fonts and locale files etc. so that when everything's up and running you can browse Chinese websites etc. and have Chinese text display properly.

I have used fcitx on Open Office, Kword, Kmail, Evolution, Mozilla Mail and it worked well for pinyin input on all of these. Never had a problem web browsing in Mozilla either, though Konqueror struggles with some sites - I guess I need to manually set fonts etc. in Konqueror or KDE settings.

If you want to use chinput or xcin for input somewhere instead of fcitx, you can just type in the line in the terminal (while logged in as the Chinese user):

$ export XMODIFIERS = @im = chinput [or xcin]

and this will set the XIM input program to whatever you pick for THAT terminal session...

another tip - browse the web for free Chinese fonts and install these (from a Windows partition is the easiest way), so you can have all the different kinds of typesettings like in the Chinese newspapers...

JDW
 
Old 11-27-2003, 09:40 PM   #10
hobylinux
Member
 
Registered: Jul 2003
Location: Ohio, USA
Distribution: Mandrake 9.2
Posts: 145

Original Poster
Rep: Reputation: 15
JDW,

thanks again. i went through and installed more of the stuff for chinese, and that also worked great--i now can use chinese no problem in openoffice.org. now i'm only left with one problem, which is that when i'm using the pinyin input, i still can't see any of the characters on the pop-up menu. any ideas anyone?

thanks again,
hoby
 
Old 11-27-2003, 09:47 PM   #11
JDW
Member
 
Registered: Feb 2003
Location: Melbourne, Australia
Distribution: Ubuntu 6.10, Slackware 11.0
Posts: 192

Rep: Reputation: 30
fcitx problems

Hi,

If all locales, fonts etc. are installed I cannot see why that happens - unless it is a bug in fcitx or the app you're using fcitx with itself...I am at work now so I can't use Linux here to check now. >:-(

I'll have a look at it over the weekend...

Cheers,

JDW
 
Old 11-30-2003, 02:36 PM   #12
hobylinux
Member
 
Registered: Jul 2003
Location: Ohio, USA
Distribution: Mandrake 9.2
Posts: 145

Original Poster
Rep: Reputation: 15
well, i had been installing the chinese stuff by going through the available packages as listed in mandrake control center and picking all the chinese ones. i decided that i might have missed some that were causing my fcitx to not display anything in the input window, so i did an update with the boot disk and chose traditional and simplified chinese as extra languages. i then reinstalled fcitx and restarted x. however, i still have the same problem. it's strange, because when i type something in pinyin, i often see a blue arrow on the right side of the input window, meaning that it thinks it's displaying multiple choices for me to pick. problem is, i can't see them.
 
Old 12-26-2003, 01:36 AM   #13
Maurice Arthur
Member
 
Registered: Jun 2001
Location: Whangarei
Distribution: KDE Ubuntu 15.04 Mint17.3
Posts: 340

Rep: Reputation: 31
fcitx

Have tried to unzip with
tar zxvf fcitx-1.8.5.tar.gz
Error Not in gzip format
That's the command printed in www.fcitx.org
to then make install
Any help
Maurice
 
Old 10-01-2004, 08:43 AM   #14
prctom
LQ Newbie
 
Registered: Oct 2003
Posts: 13

Rep: Reputation: 0
FCITX failed to input on VECTOR LINUX 4.3!

Hi!

Just downloaded latest version of FCITX
( Free Chinese Input Toy of X, an input method for Linux,"http://www.fcitx.org")

from "http://www.fcitx.org/download/fcitx-3.0.1.tar.bz2", followed its read-me to install step by step as:
1.
#tar jxvf fctx-3.0.1.tar.bz2
#cd fcitx-3.0.1
2.
#./configure
#make
#make install

3.then add a few lines in its current directory /home/~/ .bashrc :
-------------------------------------------
export LANG=zh_CN
export XMODIFIERS="@im=fcitx"
export XIM=fcitx
export XIM_PROGRAM=fcitx
--------------------------------------------

Finally, when I pressed "CTRL+Space Key", fcitx window didn't appear at all. then went to Console "fcitx", Fcitx did come out , disappointedly no chink characters appeared at input windows of fcitx ,nothing chink being inputed......

Does that imply more font sets need to be installed?how should I do with it?

has anyone been running FCITX succesffuly on vector4.0/4.3?if so ,would you be kindly share your tips with us?




regards!



Tom
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fcitx Maurice Arthur Mandriva 6 10-21-2004 07:55 PM
FCITX failed to input on VECTOR linux 4.3! prctom Linux - Software 0 10-01-2004 10:32 PM
openoffice & fcitx Maurice Arthur Mandriva 0 04-17-2004 03:30 PM
Problems, problems, problems. Lets start with the soundcard Kre8ive Linux - Newbie 5 08-07-2003 01:20 AM
Problems, problems, problems. Lets start with the ES 1868 AudioDrive Kre8ive Linux - Newbie 1 08-06-2003 07:04 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration