LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   fc29: Can't read (neither vlc nor cp) files from DVD despite setting correct region (https://www.linuxquestions.org/questions/linux-software-2/fc29-cant-read-neither-vlc-nor-cp-files-from-dvd-despite-setting-correct-region-4175650504/)

kaza 03-19-2019 04:41 PM

fc29: Can't read (neither vlc nor cp) files from DVD despite setting correct region
 
Hello!

I bought on Amazon two sets of DVDs ("Yes, minister" and "Yes, prime minister" complete
collections). Knowing that they'we marked as "US/Canada" region I thought that
I'll need to set the region code of my DVD player to "1" and that would be enough
to view/copy the files. The first set "Yes minister" played/copied without any problem,
even without the need to change the region code.

But the second set - neither "vlc" nor "cp" can read the files.
I set the region code to "1" - still the same.
I checked it with 2 disks from the second set - the same so it's probably
not a bad media issue. The DVD drive is relatively new so hardware errors in it
are also not likely (it plays other DVDs OK).

Here's what "cp" complained and the list of packages that I think are relevant:

Code:

<localhost.localdomain>.../user>ls /run/media/user/YES_PRIME_MINISTER_DISC1/VIDEO_TS/
total 7676140
-r--r--r--. 1 user user      8192 Jun 06 2003 21:15:05 VIDEO_TS.BUP
-r--r--r--. 1 user user      8192 Jun 06 2003 21:15:05 VIDEO_TS.IFO
-r--r--r--. 1 user user    141312 Jun 06 2003 20:47:19 VTS_01_0.BUP
-r--r--r--. 1 user user    141312 Jun 06 2003 20:47:19 VTS_01_0.IFO
-r--r--r--. 1 user user  25380864 Jun 06 2003 20:46:39 VTS_01_0.VOB
-r--r--r--. 1 user user 1073739776 Jun 06 2003 20:52:03 VTS_01_1.VOB
-r--r--r--. 1 user user 1073739776 Jun 06 2003 20:57:48 VTS_01_2.VOB
-r--r--r--. 1 user user 1073739776 Jun 06 2003 21:02:16 VTS_01_3.VOB
-r--r--r--. 1 user user  715866112 Jun 06 2003 21:04:35 VTS_01_4.VOB
-r--r--r--. 1 user user 1073739776 Jun 06 2003 21:07:27 VTS_01_5.VOB
-r--r--r--. 1 user user 1073739776 Jun 06 2003 21:10:18 VTS_01_6.VOB
-r--r--r--. 1 user user 1073739776 Jun 06 2003 21:13:07 VTS_01_7.VOB
-r--r--r--. 1 user user  633364480 Jun 06 2003 21:14:48 VTS_01_8.VOB
-r--r--r--. 1 user user      14336 Jun 06 2003 21:14:52 VTS_02_0.BUP
-r--r--r--. 1 user user      14336 Jun 06 2003 21:14:52 VTS_02_0.IFO
-r--r--r--. 1 user user          0 Jun 06 2003 21:14:49 VTS_02_0.VOB
-r--r--r--. 1 user user  42989568 Jun 06 2003 21:15:00 VTS_02_1.VOB
<localhost.localdomain>.../user>cp /run/media/user/YES_PRIME_MINISTER_DISC1/VIDEO_TS/VTS_01_1.VOB /home/user/Desktop/user/humor/yes_prime_minister/DVD_1
cp: error reading '/run/media/user/YES_PRIME_MINISTER_DISC1/VIDEO_TS/VTS_01_1.VOB': Input/output error
<localhost.localdomain>.../user>rpm -qa | grep gstreamer
gstreamer1-plugins-good-gtk-1.14.4-1.fc29.x86_64
gstreamer1-1.14.4-1.fc29.x86_64
gstreamer1-plugins-ugly-1.14.4-2.fc29.x86_64
gstreamer1-plugins-base-1.14.4-2.fc29.i686
gstreamer1-plugins-good-1.14.4-1.fc29.x86_64
gstreamer1-plugins-bad-freeworld-1.14.4-1.fc29.x86_64
gstreamer1-plugins-ugly-free-1.14.4-1.fc29.x86_64
phonon-backend-gstreamer-4.9.0-9.fc29.x86_64
PackageKit-gstreamer-plugin-1.1.12-2.fc29.x86_64
gstreamer1-1.14.4-1.fc29.i686
gstreamer1-plugins-bad-free-extras-1.14.4-1.fc29.x86_64
phonon-qt5-backend-gstreamer-4.9.0-9.fc29.x86_64
gstreamer1-plugins-good-extras-1.14.4-1.fc29.x86_64
gstreamer1-plugins-base-1.14.4-2.fc29.x86_64
gstreamer1-plugins-bad-free-1.14.4-1.fc29.x86_64
<root localhost.localdomain>.../root>rpm -qa | grep dvd
dvdbackup-0.4.2-11.fc29.x86_64
libdvdread-6.0.1-1.fc29.x86_64
libdvdcss-1.4.2-2.fc29.x86_64
libdvdnav-6.0.0-1.fc29.x86_64
dvd+rw-tools-7.1-29.fc29.x86_64

Have I forgot some package(s)?

TIA,
kaza.

Brains 03-19-2019 07:43 PM

Maybe the troubleshooting section of this article might work.

kaza 03-21-2019 04:32 AM

Hi Brains, thanks for the reply!

I had some success with disabling DVD menus: after starting the vlc I could open the DVD,
select "No disk menus", select "convert", select destination as H264 MP4 file on my disk and it started...
It Created an MP4 file which vlc plays OK, however there appears to be some bug in the vlc: it's "stuck"
in an endless loop of repeating the same conversion into the same destination, which causes it to pause with
a prompt asking if I want to overwrite an existing file. Before answering "yes" I copied the file to another name
and vlc continued to convert the SAME VOB file from the DVD, despite the fact that there are 8 VOB files there.
So now the question is: how to solve this "endless loop on the same file"...

TIA,
kaza.

fatmac 03-21-2019 09:34 AM

Maybe try using handbrake, I used it to rip my old DVDs to disk a while back.

https://handbrake.fr/

jefro 03-21-2019 02:39 PM

If you have a usb drive then try it on that problem system. My guess would be more a drive failure.

kaza 03-23-2019 12:35 AM

Thanks for everyone for replies, I finally found the solution.

At first I had been puzzled as to "what should create the ~/.dvdcss directory with the keys"
(which I removed per some advices on the web). Then I found that it's the "vlc"
which creates it and after that, other sw can use the keys. So, the procedure that
worked for me was:

1) Install libdvdcss package.

2) Check no mount exists for the DVD title. "umount" it if it exists. Insert DVD, mount it.

3) start vlc from command line.

4) File -> Open disk -> "No disk menus" -> play some part of DVD.
That creates the ~/.dvdcss directory with the keys.

5) dvdbackup -i /dev/<DVD device name> -p -M

6) genisoimage -dvd-video -v -o <iso_file_name>.iso <name of directory created by dvdbackup>

7) Open iso file with "ark", select VOB files, drag&drop to some folder.

Now the VOB files can be played or loaded into "avidenux", etc.

Also, the ISO file can be opened with vlc and it plays, even with menus!



Now let's see how long this procedure will work until something will change
and break it... :-)


All times are GMT -5. The time now is 06:30 PM.