Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 04-22-2008, 12:19 PM   #1
Registered: Oct 2004
Location: India
Distribution: FC 12
Posts: 233

Rep: Reputation: 30
FC-8, how to stop win partitions from automatic mount

I have FC-8 machine, which has linux and Win xp.
When I start linux, I find that all the win partitions (NTFS) are automatically mounted. They are mounted under /media directiory. For example the partition /dev/sda1 is found mounted on /media/disk. I have not added any entry in the /etc/fstab for this partition.
How can I stop this partition from getting automatically mounted.
This /dev/sda1 is my win C; drive. Incidently this partition though having "root" as its owner and group, I am able to delete files from this, that is it is mounted with permissions as "777".
There are other win partitions which contain data and I have added explicit entries in /etc/fstab to mount them.

SO friends, help me to stop this /dev/sda1 from getting mounted automatically.

Thanks in advance.

Prabhat Soni

Last edited by prabhatsoni; 04-22-2008 at 12:23 PM.
Old 04-22-2008, 12:47 PM   #2
Senior Member
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
Are you dual booting Windows XP and FC-8 ?
If so the mount point FC-8 is that not c:/windows

all the best
Old 04-22-2008, 05:11 PM   #3
Registered: Mar 2005
Location: Cascade Mountains WA USA
Distribution: Linux From Scratch (LFS)
Posts: 149

Rep: Reputation: 16
easy...add the entries to /etc/fstab
and in the options add the noauto option to the line
Old 04-22-2008, 11:48 PM   #4
Registered: Oct 2004
Location: India
Distribution: FC 12
Posts: 233

Original Poster
Rep: Reputation: 30
Thanks Taxtropel,
That would probabely serve the purpose. I will check and let you know.
But why is getting mounted anyway. What configuration options are making it getting mounted without any corresponding entry in the fstab. I feel it has something to do with the ways the flash disks are getting mounted when inserted. The flash disk too is getting mounted under the /media directory just as this /dev/sda1.

Any comments.

Prabhat Soni
Old 04-23-2008, 01:15 AM   #5
Senior Member
Registered: Apr 2008
Location: Gurgaon, India
Distribution: Cent OS 6/7
Posts: 4,629

Rep: Reputation: Disabled
If you are using FC8 then most probably the ntfs partition is getting the read write permission due ntfs-3g package that is installed by default on fedora 8.
This was not the case in earlier releases and hence ntfs needed to be mounted explicitly.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need to stop automatic login but no visible option in Yast rm200471 SUSE / openSUSE 7 02-18-2012 02:20 PM
OpenBSD stop automatic boot check if / wasn't unmounted from a crash taids *BSD 1 04-12-2006 06:55 PM
automatic mounting of windows partitions vijeesh_ep Linux - Networking 1 07-31-2004 01:05 PM
how to stop automatic system dialing shams Mandriva 0 06-03-2004 10:25 AM
can't mount swap & win partitions anymore Dominik Linux - Newbie 6 12-22-2003 09:29 AM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:01 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration