LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   "FATAL: Module not found error" using modprobe (https://www.linuxquestions.org/questions/linux-software-2/fatal-module-not-found-error-using-modprobe-690332/)

shariefbe 12-13-2008 11:39 AM

"FATAL: Module not found error" using modprobe
 
Hello,
i have an problem with modprobe command...i compiled the usbcore module and inserted using "insmod" command...and its working..when i see "lsmod" its in that list...but when i insert this module using "modprobe" i am getting the FATAL error....that is

root@sharief-desktop:/home/sharief/Desktop/drivers/core# modprobe usbcore.ko
FATAL: Module usbcore.ko not found.

i dont know whats the error...can anyone help me...

tredegar 12-13-2008 12:02 PM

Try modprobe usbcore
(no ".ko" extension)

shariefbe 12-13-2008 09:19 PM

yes...getting the same error...see

root@sharief-desktop:/home/sharief/Desktop/drivers/core# modprobe usbcore
FATAL: Module usbcore not found.

shariefbe 12-14-2008 09:22 AM

i disabled that module while compiling the kernel.....now i am trying to install manually...this is for college project...please help me

tredegar 12-14-2008 10:47 AM

From your post #1:
Quote:

when i see "lsmod" its in that list
Then the module is loaded. There is nothing else to do.

From your post #4:
Quote:

i disabled that module while compiling the kernel.....now i am trying to install manually
Recompile the kernel, and this time, mark usbcore to be loadable as a module.

shariefbe 12-14-2008 11:27 PM

Actually when i insert using "insmod" its working...and its in "lsmod" too...but when i insert using "modprobe" its not working and showing the above error message....

yes i know to recompile the kernel with that module active....but i want to insert manually...

shariefbe 12-15-2008 07:53 AM

when i insert the "usbcore module using insmod its installed...but my usb port is not working....thats why i used to do with "modprobe"....can anyone help me

shariefbe 12-17-2008 07:51 AM

now my "mobprobe usbcore" is working...usbcore is installed in my modules list...even though my usb port are not working...can anyone yell me what to do...and how to do?


All times are GMT -5. The time now is 02:06 AM.