LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-16-2016, 03:22 PM   #1
tonj
Member
 
Registered: Sep 2008
Posts: 529

Rep: Reputation: 37
FATAL: Module cifs not found


I'm running centos 6.8 on a vps and I'm stuck with this error
Quote:
# modprobe cifs
FATAL: Module cifs not found.
I started by trying to mount a samba share, and the samba share in question works fine from other machines.
Quote:
# mount -t cifs -o ....etc
mount error: cifs filesystem not supported by the system
mount error(19): No such device
so then I tried the modprobe cifs command which gave me the above FATAL: error

I've been trawling google but can't find a clear solution anywhere. I've got cifs-utils installed, and the kernel is:
Linux 2.6.32-042stab113.11 x86_64. I did yum update and saw it was updating both kernel and kernel-devel, I've also rebooted the machine after the update and reinstalled cifs but I'm still stuck with this error. Can anybody help please?

Last edited by tonj; 07-16-2016 at 03:44 PM.
 
Old 07-16-2016, 04:42 PM   #2
michaelk
Moderator
 
Registered: Aug 2002
Posts: 22,277

Rep: Reputation: 4542Reputation: 4542Reputation: 4542Reputation: 4542Reputation: 4542Reputation: 4542Reputation: 4542Reputation: 4542Reputation: 4542Reputation: 4542Reputation: 4542
You also need to install samba-client and samba-common packages.
 
Old 07-17-2016, 04:32 AM   #3
tonj
Member
 
Registered: Sep 2008
Posts: 529

Original Poster
Rep: Reputation: 37
they're both already installed and running:
Quote:
# rpm -q samba
samba-3.6.23-35.el6_8.x86_64

rpm -q samba-client
samba-client-3.6.23-35.el6_8.x86_64

# service smb status
smbd (pid 900) is running...

Last edited by tonj; 07-17-2016 at 04:35 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FATAL: Module windrvr6_usb not found. pieterparker17 Linux - Newbie 0 05-16-2011 01:08 AM
FATAL: Module off not found. cov Linux - Hardware 1 09-10-2007 05:19 PM
[SOLVED] Fatal Module not found Bryan7 Slackware 2 12-03-2006 02:02 AM
FATAL: Module usbcore not found Ross Clement Fedora 1 11-10-2004 07:54 AM
Fatal: Module HID not found. raghugs Red Hat 0 06-28-2004 12:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration