-   Linux - Software (
-   -   FATAL: Could not load /lib/modules/2.6.14-default/modules.dep no such file exist (

dr_zayus69 12-26-2005 12:51 PM

FATAL: Could not load /lib/modules/2.6.14-default/modules.dep no such file exist
Hi. I compiled a kernel and added it to the boot loader and rebooted and tried it out but i got the following error.

FATAL: Could not load /lib/modules/2.6.14-default/modules.dep no such file exist

i tried googling for it but nothing came up. Does google allow for wildcards because i think nothing came up because of the version number. I followed a book that is used to study for the Linux + test as a guide to compling the kernel. this is what i did.

1. downloaded and unpacked the kernel from
2. make xconfig
3. make
4. make modules_install
5. copied the image to /boot/
6. used Yast to add an entry to menu.1st
7. rebooted.

Did the book leave out some steps? Should i have done make dep? That wasn't mentioned in the book but i think i had to do it using a older book before. Can anyone give me some guidance? Thanks for any replies in advance.

Lenard 12-26-2005 12:59 PM

Did you forgot to customize your kernel perhaps??? Just running 'make xconfig' will produce a bad/broken kernel. Try reviewing;

If this is your first attempt at building your own kernel then you are not alone, many fail with their first few attempts (including me) at building a good working kernel.

dr_zayus69 12-26-2005 03:23 PM

well i changed some options in the configuration but left must at default because i figured they'd at least have it configured by default to work properly. This isn't my first time recompiling, but last time i did it (quite a few months back) I ended up not being able to play sound so i resorted back to the default kernel eventually. IT wasn't a big deal because i was doing it for the experience cuz i had read a lot about recompling the kernel and wanted to see what it is like. Thanks for the link - i'll check it out. Digital Hermit sounds familar so maybe i read this before or something else on the site.

dr_zayus69 12-26-2005 06:44 PM

thanks. I with that site i was able to compile and boot into the kernel. I think i read that site when i initially tried compiling a kernel but had did a fresh install since then and forgot to backup my firefox bookmarks if i did have that site bookmarked.

All times are GMT -5. The time now is 09:06 AM.