LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   failure to run wordpress due to permissions error (https://www.linuxquestions.org/questions/linux-software-2/failure-to-run-wordpress-due-to-permissions-error-4175424285/)

Greebstreebling 08-27-2012 04:24 PM

failure to run wordpress due to permissions error
 
Hi all,

I am trying to install and run wordpress using apache2 and localhost to build a local website

I installed wordpress using the synaptic package manager but when I try to run it I get the following:

Could not launch wordpress

failed to execute child process /etc/wordpress/wp-config.php

permission denied
I am running a deb 6 desktop machine at home and there are only two users, me and me as root

can anyone tell me what to do?

thanks
Paul

szboardstretcher 08-27-2012 04:29 PM

Either your file permissions are wrong, or you have SElinux enabled and it is messing with it.

Greebstreebling 08-27-2012 04:35 PM

thanks
 
sorry I am completely new to this, what permissions would i need as a user and how would I set them up?

thanks
Paul

Greebstreebling 08-27-2012 04:57 PM

tried this
 
I tried chown paul /etc/wordpress

and chown paul /etc/wordpress/wp-config.php

neither seem to have helped unfortunately

also checked selinux and it's not installed on my system

any help gratefully received
Paul


All times are GMT -5. The time now is 12:52 PM.