LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-26-2010, 04:02 AM   #1
chiendarret
Member
 
Registered: Mar 2007
Posts: 255

Rep: Reputation: 16
Failure to re-establish 3D video acceleration


Following a reinstall of debian amd64 lenny I am unable to get 3D acceleration (which was working fine before), although all checks are positive:

###########
francesco@tya64:~$ glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,
GLX_EXT_texture_from_pixmap, GLX_ARB_multisample, GLX_NV_float_buffer,
GLX_ARB_fbconfig_float
client glx vendor string: NVIDIA Corporation
client glx version string: 1.4
....................
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 6600/PCI/SSE2
OpenGL version string: 2.1.2 NVIDIA 173.14.09
###################


&&&&&&&&&
francesco@tya64:~$ grep Driver /etc/X11/xorg.conf 2>&1 |grep nvidia
Driver "nvidia"
&&&&&&&&&&&&&&

%%%%%%%%%%
tya64:/home/francesco# adduser francesco video
The user `francesco' is already a member of `video'.
%%%%%%%%%%

@@@@@@@@@
$ glxgears

it is as slow as on another machine i386 lenny without nvidia driver and without acceleration. This confirms that 3D is not working.
@@@@@@@@@


Adding the line

option "ForcePCIMode" "True"

to /etc/X11/xorg.conf (section Device)
did not help, and was therefore removed.

Thanks for help

francesco pietra
 
Old 02-27-2010, 01:11 PM   #2
resetreset
Senior Member
 
Registered: Mar 2008
Location: Cyberspace
Distribution: Dynebolic, Ubuntu 10.10
Posts: 1,340

Rep: Reputation: 62
I just wanted to say that I'm waiting for an answer to this as well!
 
Old 02-28-2010, 02:16 PM   #3
chiendarret
Member
 
Registered: Mar 2007
Posts: 255

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by resetreset View Post
I just wanted to say that I'm waiting for an answer to this as well!
I posted also on debian forums. Nothing useful came out.
 
Old 03-02-2010, 11:26 AM   #4
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 399Reputation: 399Reputation: 399Reputation: 399
Your glxinfo output shows that direct rendering is, in fact working. glxgears is not a benchmark and should never, ever, ever be used to determine if 3D acceleration is working. Have you tried other applications such as openarena?

Adam
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
trying to get 3D acceleration in video card girtart3d Linux - Software 7 01-23-2008 04:53 PM
video acceleration ? or what ... please help trukin Linux - Software 2 06-05-2007 03:53 PM
SuSE 10 no video acceleration shingalated SUSE / openSUSE 4 11-22-2005 06:18 PM
Video Acceleration (10.0 Official) askjeffro Mandriva 1 06-01-2004 01:02 PM
WHY cant i get video acceleration V_LESTAT Linux - Newbie 16 02-25-2004 04:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration