-   Linux - Software (
-   -   Failed to bring up wlan0 (

jon_k 12-26-2004 10:35 AM

Failed to bring up wlan0
Here's a session of me that does not seem to help get my card up.

root@0[~]# ndiswrapper -i /mnt/hdc1/etc/ndiswrapper/sspciv27/sspciv27.inf
root@0[~]# ndiswrapper -m
root@0[~]# wlcardconfig
root@0[~]# ifup eth0

It did once, I got it working with WEP and everything, but then when I did ifdown wlan0 and then re-did wlancardconfig to set it up as ad-hoc, it has yet to come back up, even when I revert it back to the way it was when I had it working.

Now, it just sits forever during ifup wlan0 then gives me an error.
root@0[~]# ifup wlan0
Operation failed.
Failed to bring up wlan0.

During the point when it is 'sitting there' I can type ifconfig and I'll see it with the following settings:

wlan0 Link encap:Ethernet HWaddr 00:02:DD:33:6C:57
inet6 addr: fe80::202:ddff:fe33:6c57/64 Scope:Link
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:54 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:12352 (12.0 KiB)
Interrupt:10 Memory:df000000-df001fff

However, when it says operation failed, it will disappear from ifconfig.

When I type ndiswrapper -l I get this:
ndiswrapper -l
Installed ndis drivers:
sspciv27 hardware NOT present

Does anything seem to be wrong with my configuration? Also, why don't I get an inet addr in wlan0 when I run ifconfig?

Any help would be great!

(not sure if this is a hardware or software problem, but it seems to be a software config issue, so I posted in software forum)

jon_k 12-26-2004 11:20 AM

I got it working after a lot of work.

Now, for some reason with both eth0 and wlan0 up, I can ping my local network router, however if I try to ping somebody like, I don't get any replies.

How can I get the internet to be able to reach my computer with 2 netcards enabled?

msmales 12-31-2004 05:56 PM

I suppose it is common sense to have just one network card enabled at a time. Also, I had exactly the same problem as you so I fixed it about an hour ago..... here goes like this:..

While you may be able to ping your router but not using your wireless card, try issuing a "route", if you notice that the last line does not have a gateway ip address and does not reference the wlan0 interface try this...


route add default gateway <ip address of you router or access point>
# in my case the router's ip address is, but it might be something like on your setup

* If you still can't get onto the internet (but you can ping your router) see if the file /etc/resolv.conf exists, if not then you won't be able to resolve ip addresses, make a resolv.conf like so...

#Become root

su -

<type in root password>
#Check you can ping you router, the ip address will vary on different routers, but it's generally either or

#Use your favourite text editor to make /etc/resolv.conf

vi /etc/resolv.conf
#insert the following line into /etc/resolv.conf

#You should now be able to ping stuff on the internet, try going somewhere in a browser too :)


All times are GMT -5. The time now is 12:44 AM.