LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Failed/Missing Dependency when installing software (https://www.linuxquestions.org/questions/linux-software-2/failed-missing-dependency-when-installing-software-583842/)

megerdin 09-11-2007 06:32 AM

Failed/Missing Dependency when installing software
 
Hi
I m using FC7. Just before I try to installl postfix-pflogsumm.i386 2:2.4.3-2.fc7 for mail analysing. thats why I upgrade my postfix to postfix-2.4.3-2.fc7.i386.rpm

when i try to install it say..

Quote:

[root@Server1 Fedora_7]# rpm -ivh postfix-2.4.3-2.fc7.i386.rpm
Preparing... ########################################### [100%]
package postfix-2.4.3-2.fc7 is already installed
When i run the command .. the output is..
Quote:

[root@Server1 Fedora_7]# yum -y install postfix-pflogsumm
Loading "installonlyn" plugin
Setting up Install Process
Parsing package install arguments
fedora 100% |=========================| 2.1 kB 00:00
updates 100% |=========================| 1.9 kB 00:00
Resolving Dependencies
--> Running transaction check
---> Package postfix-pflogsumm.i386 2:2.4.3-2.fc7 set to be updated
--> Processing Dependency: perl(Date::Calc) for package: postfix-pflogsumm
--> Processing Dependency: postfix = 2.4.3-2.fc7 for package: postfix-pflogsumm
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package perl-Date-Calc.i386 0:5.4-1.2.2.1 set to be updated
---> Package postfix-pflogsumm.i386 2:2.4.3-2.fc7 set to be updated
--> Processing Dependency: perl(Bit::Vector) for package: perl-Date-Calc
--> Processing Dependency: perl(Carp::Clan) for package: perl-Date-Calc
--> Processing Dependency: perl-Bit-Vector >= 6.4 for package: perl-Date-Calc
--> Processing Dependency: postfix = 2.4.3-2.fc7 for package: postfix-pflogsumm
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package perl-Carp-Clan.noarch 0:5.9-1.fc7 set to be updated
---> Package perl-Date-Calc.i386 0:5.4-1.2.2.1 set to be updated
---> Package postfix-pflogsumm.i386 2:2.4.3-2.fc7 set to be updated
---> Package perl-Bit-Vector.i386 0:6.4-2.2.2.1 set to be updated
--> Processing Dependency: postfix = 2.4.3-2.fc7 for package: postfix-pflogsumm
--> Finished Dependency Resolution
Error: Missing Dependency: postfix = 2.4.3-2.fc7 is needed by package postfix-pflogsumm
So to solve the problem what can i do.

Plz any sugestion..

macemoneta 09-11-2007 04:16 PM

Try removing the package (which does not appear to be fully/properly installed:

Code:

rpm -e postfix
Then re-install with yum:

Code:

yum install postfix postfix-pflogsumm


All times are GMT -5. The time now is 06:34 AM.