LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-20-2012, 02:40 PM   #1
devdevk
LQ Newbie
 
Registered: Jun 2012
Posts: 4

Rep: Reputation: Disabled
Failed dependency - libpython2.4.so.1.0


I am attempting to install Oracle Virtual Box onto a RedHat EL 5.4.

When i run the Virtual Box rpm i get the message " libpython2.4.so.1.0 is needed by Virtual Box-4.1-4.1.16_rhel5-1.1386.

I have looked for the "libpython2.4.so.1.0" on the web and am not able to find any site that has a version for RedHat.

I am an intermediate Linux user. Can someone please point me in the right direction.

Thank you
 
Old 06-20-2012, 04:27 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,328

Rep: Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583
Welcome to LQ.

A lot of things wouldn't work if you had no libpython2.4.so.1.0.
( The file is provided by the package 'python-libs' : $ rpm -qa python-libs ).

I'd guess that your OS is 64bits ? The command : 'uname -m' will tell.

Quote:
I have looked for the "libpython2.4.so.1.0" on the web ..
/usr/lib64/libpython2.4.so.1.0 is probably the location on your OS.

.
 
1 members found this post helpful.
Old 06-20-2012, 08:11 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,465

Rep: Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606
Quote:
I have looked for the "libpython2.4.so.1.0" on the web and am not able to find any site that has a version for RedHat.
you MISSED the one that 100% DOSE have it
red hat
it is in the rhn repos

Code:
su -
yum search python 
-- it is in that list --
--- and if it is installed there will be an "i" in front of the name --
yum install python-libs
mater of fact the red hat software updater "yum" will not work if python is not installed
so it IS installed , and this one IS current
python-libs-2.4.3-46.el5_8.2.i386.rpm ( for centos5.8)

however seeing a oracle wants you to use THEIR version of rhel5 or RHEL6 ( called " unbreakable Linux 5 , or 6 ")
they might use a slightly different name than Red Hat dose
libpython2.4.so.1.0 might be listed in the /usr/lib folder as "libpython2.4.so.1"
if so make a link to the new name

BUT
seeing as BOTH the Oracle database, AND RHEL5 are not free and you NEED to pay for the support contract for BOTH software packages from two different companies
you might want to buy Oracle's "unbreakable Linux 5" so you are only paying ONE company

and install the Oracle database ON Oracle's Operating System

Last edited by John VV; 06-20-2012 at 08:20 PM.
 
Old 06-21-2012, 12:46 PM   #4
devdevk
LQ Newbie
 
Registered: Jun 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thank you for the reply knudfl and Joun VV.

I was able to find the "libpython2.4.so.1.0" in the /usr/lib64 directory.

When i rand the "yum search python" John VV, i did not see it listed.

Please let me know the steps to make a link to the new name.

Thank you for you help.
 
Old 06-21-2012, 01:01 PM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,328

Rep: Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583
Quote:
I am attempting to install Oracle Virtual Box onto a RedHat EL 5.4.
Should be OK, when you use a 64bits version of Virtual Box, I guess.

VirtualBox-4.1-4.1.16_rhel5-1.1386 is not a package for your OS.


.

Last edited by knudfl; 06-21-2012 at 01:04 PM.
 
Old 06-21-2012, 01:07 PM   #6
devdevk
LQ Newbie
 
Registered: Jun 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
I am using version 4.1.18 for Linux for RHE Linux 5.

I did a clean install this morning and selected all the option for Software Development and Web Server to catch everything and ran the Virtual Box install again and get the same error "libpython2.4.so.1.0 is needed by VirtualBox-4.1-4.1.18_78361_rhel5-1.i386.

What do i do next?
 
Old 06-21-2012, 02:33 PM   #7
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,328

Rep: Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583Reputation: 3583
! Wrong package : VirtualBox-4.1-4.1.18_78361_rhel5-1.i386 !

Please use : VirtualBox-4.1-4.1.18_78361_rhel5-1.x86_64.rpm !

http://dlc.sun.com.edgesuite.net/vir...5-1.x86_64.rpm


.
 
Old 06-21-2012, 05:36 PM   #8
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,465

Rep: Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606
Quote:
I was able to find the "libpython2.4.so.1.0" in the /usr/lib64 directory.
that RIGHT THERE IS YOUR PROBLEM
a 64 bit OS on a 32 bit VM
won't work

use the 64 bit vm !!!
VirtualBox-4.1-4.1.18_78361_rhel5-1.x86_64.rpm !

Quote:
When i rand the "yum search python" John VV, i did not see it listed.
you did not see "python-lib" listed ??????
odd ,it is part of the base system and is a required program to be installed


did you pay red hat for the required support contract ? - you MUST pay red hat to use RHEL
because that package in in the RHN repo
 
Old 06-22-2012, 10:21 AM   #9
devdevk
LQ Newbie
 
Registered: Jun 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thank you John VV,

Downloaded and was able to install without any issue.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Failed dependency sethusubbiah Linux - Software 13 07-19-2012 08:41 PM
Dependency resolution failed mshawabkeh Linux - Newbie 8 03-12-2009 01:27 PM
libpython2.4.so.1.0 taylorchase Linux - Software 2 05-10-2007 06:32 PM
failed dependency vijaysh Debian 1 12-26-2004 04:18 AM
how to solve failed dependency when dependency exists dwcramer Linux - Newbie 2 08-24-2004 10:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration