LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-10-2011, 01:44 AM   #1
garima721
LQ Newbie
 
Registered: Sep 2011
Posts: 4

Rep: Reputation: Disabled
Unhappy Failed dependencies while installing Networker 7.6 on RHEL 6


I was trying to install networker 7.6 on RHEL 6 but it gave following error when installing NW packages-

error: Failed dependencies:
/bin/ksh is needed by lgtoclnt-7.6.2.1-1.x86_64
libc.so.6 is needed by lgtoclnt-7.6.2.1-1.x86_64
libc.so.6(GLIBC_2.0) is needed by lgtoclnt-7.6.2.1-1.x86_64
libc.so.6(GLIBC_2.1) is needed by lgtoclnt-7.6.2.1-1.x86_64
libc.so.6(GLIBC_2.1.2) is needed by lgtoclnt-7.6.2.1-1.x86_64
libc.so.6(GLIBC_2.1.3) is needed by lgtoclnt-7.6.2.1-1.x86_64
libc.so.6(GLIBC_2.2) is needed by lgtoclnt-7.6.2.1-1.x86_64
libc.so.6(GLIBC_2.3) is needed by lgtoclnt-7.6.2.1-1.x86_64
libc.so.6(GLIBC_2.3.2) is needed by lgtoclnt-7.6.2.1-1.x86_64
libcap.so.1()(64bit) is needed by lgtoclnt-7.6.2.1-1.x86_64
libdl.so.2 is needed by lgtoclnt-7.6.2.1-1.x86_64
libdl.so.2(GLIBC_2.0) is needed by lgtoclnt-7.6.2.1-1.x86_64
libdl.so.2(GLIBC_2.1) is needed by lgtoclnt-7.6.2.1-1.x86_64
libm.so.6 is needed by lgtoclnt-7.6.2.1-1.x86_64
libpthread.so.0 is needed by lgtoclnt-7.6.2.1-1.x86_64
libpthread.so.0(GLIBC_2.0) is needed by lgtoclnt-7.6.2.1-1.x86_64
libpthread.so.0(GLIBC_2.1) is needed by lgtoclnt-7.6.2.1-1.x86_64
libpthread.so.0(GLIBC_2.2) is needed by lgtoclnt-7.6.2.1-1.x86_64
librt.so.1 is needed by lgtoclnt-7.6.2.1-1.x86_64
libstdc++.so.5()(64bit) is needed by lgtoclnt-7.6.2.1-1.x86_64
libstdc++.so.5(CXXABI_1.2)(64bit) is needed by lgtoclnt-7.6.2.1-1.x86_64
libstdc++.so.5(GLIBCPP_3.2)(64bit) is needed by lgtoclnt-7.6.2.1-1.x86_64


What am I supposed to do? I am not getting these packages on Googling too
 
Old 10-10-2011, 02:15 AM   #2
kasl33
Member
 
Registered: Oct 2004
Location: USA
Distribution: Ubuntu-Server, Mac OS X, Arch Linux
Posts: 356

Rep: Reputation: 48
It's funny that this comes up - I literally just finished writing a tutorial about how to do this. See http://kaslit.com/blog.php?id=83

Now, to keep you at the LQ site, try this (for each dependency) as root:

Code:
yum whatprovides libc.so.6
It will tell you what file to install such as glibc-2.12-1.7.el6_0.5.i686

To install the file that contains the libc.so.6 dependency, just simply do this:

Code:
yum install glibc.i686
Notice that I didn't include anything after glibc (I ommited the -2.12-1.7.e16_0.5.), but I included the i686 because I'm on a 64-bit machine.

The rest of the dependencies will work just the same way. As you work your way through them, the program will then install.

DO NOT USE MY VERSION NUMBERS AS I AM PROBABLY ON A DIFFERENT DISTRIBUTION WITH DIFFERENT VERSIONS THAN YOU
 
Old 10-10-2011, 02:33 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2019 CentOS6.10 CentOS7.5 + 50+ other Linux OS, for test only.
Posts: 17,211

Rep: Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548Reputation: 3548
@garima721 : Welcome to LQ.

Looks like you are trying to install the 64bits lgtoclnt-7.6.2.1
into a 32bits EL6. That's an impossible attempt.


The command 'uname -m' will reply with your architecture. ( i686 ? )

..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Install SVK on RHEL 4 - Failed dependencies error. nobitavn Linux - Software 4 10-11-2010 06:21 AM
Failed Dependencies when trying to install OpenOffice 3.2.1 on RHEL 5 akashj87 Linux - Software 2 06-23-2010 12:19 PM
cannot install Hobbit in Rhel 5, failed dependencies librrd.so ae14balt1c Linux - Newbie 1 04-29-2010 07:42 AM
Failed dependencies while installing nspluginwrapper jaymoney Fedora 1 12-06-2008 10:47 AM
Failed dependencies installing MPlayer qwerty Linux - Software 7 10-24-2005 04:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration