LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-13-2010, 01:46 AM   #1
asif123
LQ Newbie
 
Registered: Sep 2010
Posts: 3

Rep: Reputation: 0
Facing "Cannot find ssl headers" for SUSE machine while configuring NAGIOS


Hello,
Actually I need to install configure file of NRPE 2.12 for monitoring the SUSE machine from NAGIOS(Linux machine). But once I am trying to install configure file of the NRPE 2.12 its giving error "cannot find SSL headers". I downloaded libssl-dev files which are in the format of .deb but its not getting install on SUSE. Please let me know how to resolve this error ASAP as I am getting stuck in the middle.
 
Old 09-14-2010, 11:15 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2019 CentOS6.10 CentOS7.5 + 50+ other Linux OS, for test only.
Posts: 17,206

Rep: Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547
Welcome to LQ.

Please open a terminal window and type : 1) su
2) zypper in libopenssl-devel

... Or use the 'Package Manager' (Yast) for the install.

...
 
Old 09-22-2010, 05:36 AM   #3
asif123
LQ Newbie
 
Registered: Sep 2010
Posts: 3

Original Poster
Rep: Reputation: 0
not worked

Quote:
Originally Posted by knudfl View Post
Welcome to LQ.

Please open a terminal window and type : 1) su
2) zypper in libopenssl-devel

... Or use the 'Package Manager' (Yast) for the install.

...

HI,

thanks for the suggestion.
I checked on my SLES machine whether this package is installed or not using YAST and found that

libopenssl0_9_8-0.9.8h-30.11
libopenssl0_9_8-32bit-0.9.8h-30.11
openssl-certs-0.9.8h-25.14
openssl-0.9.8h-30.11

are already installed.

Still I am getting the same error. Please help me out.
 
Old 09-23-2010, 11:01 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2019 CentOS6.10 CentOS7.5 + 50+ other Linux OS, for test only.
Posts: 17,206

Rep: Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547
And very clearly, libopenssl-devel is not installed.


None of the listed packages can be used for building software.

All development files are in packages "-devel".


Please tell, which Suse version, this is about. SLES 10 ? SLES 11 ?
The command : 'cat/etc/issue' and / or
'cat /etc/SuSE-release' will show the version.
..

Last edited by knudfl; 09-23-2010 at 02:48 PM.
 
Old 10-11-2010, 10:33 PM   #5
asif123
LQ Newbie
 
Registered: Sep 2010
Posts: 3

Original Poster
Rep: Reputation: 0
Hi,
Thanks for the suggestion.
Detials are as foolows:
SUSE Linux Enterprise Server 11 (x86_64)
VERSION = 11
PATCHLEVEL = 0
 
Old 04-26-2011, 07:28 AM   #6
Pawcio
LQ Newbie
 
Registered: Apr 2011
Location: Poznan, Poland
Distribution: ArchLinux
Posts: 2

Rep: Reputation: 0
Hi!
I'm new here but I think I can help (if this is still actual ;-) )

If you're using SLES11 you should download SLES development DVDs and add them to YaST repository.

ISO's are available from Novell.

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot find Nagios web interface (Nagios 3.2.0) and O/S = Fedora 10 gutiojj Linux - Newbie 7 02-04-2010 08:55 AM
facing problem while install SRILM toolkit on linux machine(i686) vinaysuryawanshi Linux - Desktop 1 06-08-2008 03:04 PM
while configuring KDevelop, can't find 'qt' headers and libraries. himy Linux - Newbie 2 09-07-2007 07:15 PM
How to I find my machine name (in SuSE 9.2)? DeekBeek Linux - Newbie 2 07-11-2005 01:49 PM
Facing problem while configuring OpenLDAP server shanu Linux - Software 1 03-13-2005 04:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration