-   Linux - Software (
-   -   f-prot anti-virus "Segmentation fault" error and other weird stuff (

dalek 10-14-2003 02:23 AM

f-prot anti-virus "Segmentation fault" error and other weird stuff
I run f-prot on occasion and I get a Segmentation fault error and it stops. It does this in different directories on different occasions. I noticed that in KDS System Guard, it lists the process status as "disk sleep". What is that? It is not running at all. No CPU time or nothing. I also can't get a kill -9 pid command to kill it. It doesn't return a error or anything, it just doesn't go away.

I have also noticed that when this happens some things won't open. Example, I can be in File Manager - Super User and click on a config file, or any text file, and it says it can't launch kwrite. I can go into a term as root and launch kwrite and open the file just fine.

I have also noticed that sometimes when it is really bad that I get can't umount errors when shutting down. I only have one hard drive that contains the OS. My second drive is for data only. So it has to be spinning right?

I think I have a bad setting somewhere but I don't know where to even start.

One more tidbit, I can reboot and everything goes back to normal. I don't usually shut down this rig. It is sometimes up for weeks. It does this even on a fresh install sometimes.

Any ideas on what the heck is going on??? Anybody ever seen anything like this?

Thanks guys

:confused: :D :D :D :D :D

Just in case. /etc/fstab file

/dev/hda6 / ext3 defaults 1 1
/dev/hda5 /boot ext3 defaults 1 2
none /dev/pts devpts mode=0620 0 0
/dev/hda7 /home ext3 defaults 1 2
none /mnt/cdrom supermount dev=/dev/scd0,fs=auto,ro,--,iocharset=iso8859-1,codepage=850,umask=0 0 0
none /mnt/cdrom2 supermount dev=/dev/hdd,fs=auto,ro,--,iocharset=iso8859-1,codepage=850,umask=0 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=auto,--,iocharset=iso8859-1,sync,codepage=850,umask=0 0 0
/dev/hdb1 /mnt/windows vfat iocharset=iso8859-1,codepage=850,umask=0 0 0
none /proc proc defaults 0 0
/dev/hda1 swap swap defaults 0 0
/dev/hda9 swap swap defaults 0 0
/dev/hda10 /mnt/gentoo reiserfs rw 0 0
/dev/hda8 /mnt/gentoo/boot ext3 rw 0 0

/dev/scsi/host0/bus0/target0/lun0/cd /mnt/cdrecorder auto ro,noauto,user,exec 0 0

/etc/mtab file

/dev/hda6 / ext3 rw 0 0
none /proc proc rw 0 0
none /proc/bus/usb usbdevfs rw 0 0
none /dev devfs rw 0 0
/dev/hda5 /boot ext3 rw 0 0
none /dev/pts devpts rw,mode=0620 0 0
/dev/hda7 /home ext3 rw 0 0
none /mnt/cdrom supermount ro,dev=/dev/scd0,fs=auto,--,iocharset=iso8859-1,codepage=850,umask=0 0 0
none /mnt/cdrom2 supermount ro,dev=/dev/hdd,fs=auto,--,iocharset=iso8859-1,codepage=850,umask=0 0 0
none /mnt/floppy supermount rw,sync,dev=/dev/fd0,fs=auto,--,iocharset=iso8859-1,codepage=850,umask=0 0 0
/dev/hdb1 /mnt/windows vfat rw,iocharset=iso8859-1,codepage=850,umask=0 0 0
/dev/hda10 /mnt/gentoo reiserfs rw 0 0
/dev/hda8 /mnt/gentoo/boot ext3 rw 0 0

edit: forgot to put a "." at the end of a sentence. I don't know what is worse my tpying or my pofradin. :confused:

dalek 10-14-2003 03:38 AM

More info
I decided to reboot and it got weird. I chose logout and I usually get the graphical thing to reboot/login etc. I did not get that. It went to command line. I logged in as root and typed in "init 6". It said switching runlevels and sending the term signal and just sat there. Nothing. I typed in runlevel and it said 5 6. I assume that is it's way of saying in 5 switching to 6. :confused: I was back at a prompt so I typed in "shutdown -r now" and it said switching runlevel and sending the term signal like before and just sat there. It did lock out the other consoles though, stupid thing. It was not locked up. If I hit a button it would come up on the screen and such but no prompt anymore.

Hit reset button. Of course it was pissed about the bad shutdown and all but here I am again.

What is wrong with this stupid thing? I have noticed that it is worse when running with the NVIDIA drivers installed. Could that make a difference?

Somebody tell me I'm not completely nuts here. :scratch: :scratch:

Not happy now, just :confused: :confused: :confused: and about to :cry: :cry:

dalek 10-14-2003 04:19 AM

After rebooting, f-prot ran just fine.

Still :confused: and about to :cry: :cry: :cry:


dalek 10-15-2003 01:53 AM

Guess I'm going nuts huh


It is small but in a big way.

still about to :cry: :cry: :cry: :cry:

dalek 10-21-2003 08:30 AM

It just did it again. I also noticed that the right click on the desktop didn't work.

I also did this. I switched to runlevel 3 and still got the same error, segmentation fault. I then changed to runlevel 1 and got the same error. That eliminates a lot.

I also typed in mount. Everything appeared to be mounted properly. I also noticed that it would not let me kill any processes. No errors, it just didn't kill it. It would not die. That would be f-prot which hung up after the boo boo.

I'm not exactly looking for a fix. I'm looking for a way to narrow this problem down to a specific program or something. Can someone give me some commands to run to see what is wrong? Has anyone seen this before? Any info would be nice.

I was using f-prot to test with since it scans all files. It still stops in different places. If it were just f-prot then I would think f-prot was the problem but it is a lot of other things to. It won't let me open kwrite from file manager - super user. The right click on desktop not working. Some other things listed above.



:confused: :D :D :D

dalek 10-21-2003 09:04 AM

I also noticed that postfix had a boo boo too. It just said failed when the service stopped.

May help make a difference.

Any ideas??

:confused: :scratch: :D :D :D

Baldorg 10-21-2003 05:23 PM


Maxtor 30Gb HD
Theres your problem....

dalek 10-21-2003 06:16 PM

Huh? What's wrong with my drive?

:confused: :confused: :confused: :confused: :D

Baldorg 10-22-2003 05:44 PM

Well, the brand/model has a bad reputation of crapping out.

dalek 10-22-2003 08:37 PM

Is there one that doesn't break? I've seen Samsung, IBM, Western Digital and all the major ones break. I don't really think it's the drive because Gentoo has no problem, just Mandrake. If it was the drive I would think Gentoo would have some problem or other.

What you think? What brand would you use?


:scratch: :confused: :D :D :D

All times are GMT -5. The time now is 07:02 PM.