-   Linux - Software (
-   -   "Extra bytes at the end of class file" when installing WTK2.2 (

eikeland 02-17-2007 11:54 AM

"Extra bytes at the end of class file" when installing WTK2.2
I am trying to install WTK2.2 on Mandriva 2006 x64, but I am having a problem. I first install jdk-6, and it installs without problems.
The path is /usr/java/jdk1.6.0/bin
The files in this directory are:
appletviewer* javac* jinfo* jstatd* rmid* wsgen*
apt* javadoc* jmap* keytool* rmiregistry* wsimport*
extcheck* javah* jps* native2ascii* schemagen* xjc*
idlj* javap* jrunscript* orbd* serialver*
jar* jconsole* jsadebugd* pack200* servertool*
jarsigner* jdb* jstack* policytool* tnameserv*
java* jhat* jstat* rmic* unpack200*

When I try to install the Wireless Toolkit
I the path of the java interpreter:
but I get this error:
Testing /usr/java/jdk1.6.0/bin/java...
Exception in thread "main" java.lang.ClassFormatError: Extra bytes at the end of class file com/sun/kvem/environment/JavaVersionTester
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(
at Method)
at java.lang.ClassLoader.loadClass(
at sun.misc.Launcher$AppClassLoader.loadClass(
at java.lang.ClassLoader.loadClass(
at java.lang.ClassLoader.loadClassInternal(
/usr/java/jdk1.6.0/bin is not a suitable Java interpreter
Enter a path to a Java 2 SDK (For example: /user/jdk1.4/bin). You can type "exit" to cancel installation.

I have also tried:
but I get the same error.

Any suggestions what's wrong here??

eikeland 03-06-2007 08:59 PM

I worked around this by un-installing 1.6 and installing jdk1.5.0_06.

All times are GMT -5. The time now is 04:28 PM.