Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 08-06-2012, 02:43 AM   #1
LQ Newbie
Registered: Jun 2009
Distribution: Ubuntu 12.03 Gnome Shell
Posts: 4

Rep: Reputation: 0
External links won't launch Firefox

Hi, I was working with Chromium since a year or more without any problem. As Chromium is not updated in the ppa since version 18 I have removed it and switched back to Firefox.
I made Firefox the default browser but clicking a ling inside email (thunderbird) continues to launch Chromium. So I removed Chromium, and now when I click a url link from inside Thunderbird it does not launch nothing at all ... no reaction at all. Of course I can copy and paste the link manually to Firefox and it works, but it's a pain.

I have already check the following:
- Firefox IS the default browser. It is set both in Firefox and in Gnome applications setting
- In: ~/.local/share/applications/mimeapps.list , firefox is well configured
- Also in: /usr/share/applications/defaults.list

I use Ubuntu 12.04.
The same occurs either I login with Unity or Gnome 3
I discovered this with Firefox 14.01 (did not used it before, so I don't know if it would work ok with previous versions). Now I have updated to Firefox 15 from the ppa beta channel... no change in the behaviour.

Thanks for any help...
Old 08-07-2012, 11:24 AM   #2
Registered: Jan 2011
Location: New Mexico
Distribution: Xubuntu Core
Posts: 182

Rep: Reputation: 58
I'm not a Thunderbird user, but is there something in the T-bird GUI setup that has a Preferred Applications choice (not "Default", just "Preferred")?
1 members found this post helpful.
Old 08-07-2012, 12:19 PM   #3
LQ Newbie
Registered: Jun 2009
Distribution: Ubuntu 12.03 Gnome Shell
Posts: 4

Original Poster
Rep: Reputation: 0
Hi Albinar, I have found the solution ... there is in reality something in the Thunderbird setup. I had to go to Edit > Preferences > Attachments and select "Contents type" as HTML and HTMLS, then changed it from "Firefox" to "Always Ask". Then when I clicked a link a dialog appears asking for an action. I choose "open in Firefox" and "not ask again" .... and that's it. It works !! Thanks.

Last edited by Ptah56; 08-07-2012 at 12:20 PM.


brower, default, firefox, link

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
T'Bird won't launch links raysr SUSE / openSUSE 2 01-30-2009 10:01 PM
Thunderbird won't launch firefox OC_eobard Linux - Software 4 07-11-2006 07:29 PM
firefox won't open links in new window lukameen Slackware 13 03-15-2005 07:14 AM
Firefox 1.0 won't launch w/Jre1.5.0 installed raysr Linux - Software 6 11-11-2004 01:55 PM
external launch of firefox... Borelian Linux - Software 1 05-09-2004 05:50 AM

All times are GMT -5. The time now is 04:50 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration