LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Exim4 undeliverable emails"failed to chdir to /home/paul" (https://www.linuxquestions.org/questions/linux-software-2/exim4-undeliverable-emails-failed-to-chdir-to-home-paul-445134/)

PK2K 05-15-2006 06:31 PM

Exim4 undeliverable emails"failed to chdir to /home/paul"
 
Hi

On my Debian Sarge box all incoming email gets stuck in the mailq with error "failed to chdir /home/paul". This happens for all users. I suspect it might have started after adding courier-imap, from what I could see the users mail store changed to their home directory and then mail delivery stopped.

I have tried creating a test user and recursively 0777'ing the home directory but still I get the same error. I am still sure it is a permissions thing but haven't been able to find the user or group that email is delivered from.

I have tried sending emails from mutt, squirrelmail, and telnet on the local machine, but they all get stuck in the q and eventually returned undeliverable.

/var/log/exim4/mainlog says "R=local_user T=mail_spool defer (13): Permission denied failed to chdir to /home/paul"

Any suggestions appreciated.


All times are GMT -5. The time now is 04:41 PM.