-   Linux - Software (
-   -   Executing apps in gnome as root doesn't keep GTK theme (

Mr. Swillis 07-24-2006 07:20 PM

Executing apps in gnome as root doesn't keep GTK theme
Hi all,

I am running Fedora 5 and have noticed one strange thing that I am sure has a simple answer. I am logged in as myself (non-root user) and have noticed that when I execute a gui app as root, it doesn't use the GTK themes as it does when I execute as myself.

The only other primarily Gnome system I have used is Ubuntu, and don't recall that happening, but in that case I was using sudo instead of running as root.

This isn't really a huge deal, I was just kind of curious why this is happening and whether there was an easy "fix" for it.


Mr. Swillis

leonscape 07-24-2006 07:36 PM

This is normal, it will automatically use the settings defined for root, as its the root user who is executing the app. It makes sense once you think about it... after all you are pretending to be root, and you do need path settings etc.

To fix this simply set the root users theme the same as your normal user.

I delibratley keep them different, as a reminder to myself mainly.. and also to catch anything suspicious.

Mr. Swillis 07-24-2006 07:40 PM

Awesome, thanks for the super quick reply. I figured it would be something simple like that.

All times are GMT -5. The time now is 04:42 AM.