-   Linux - Software (
-   -   evolution not honoring XFCE default browser (

nilleso 04-16-2007 11:46 AM

evolution not honoring XFCE default browser
Hello. In the mail application evolution, all URLs are opened with firefox despite the preferred web browser being opera in the XFCE preferred apps.
Any clues?

cheers :)

MS3FGX 04-16-2007 06:36 PM

I have not used Evolution specifically, but that doesn't sound like unusual behavior to me. The XFCE preferred applications is for XFCE itself as well as programs built on the XFCE framework that you may use down the line. Since Evolution is neither of those, it is not going to obey those settings.

Again, not having specific Evolution experience I can't say where exactly it will be, but Evolution should have it's own option in the configuration to select the default browser things will be opened in.

RemusX2 04-17-2007 12:43 AM

If you issue these two commands within a terminal, with some adjustment for Opera, it should work:


gconftool-2 --set /desktop/gnome/url-handlers/http/command -t string 'mozilla %s'

gconftool-2 --set /desktop/gnome/url-handlers/https/command -t string 'mozilla %s'

nilleso 04-17-2007 09:01 AM

awesome. Thank you so much. I used the following cmd's because simply using 'opera %s' overwrote the current tab instead of opening a new one which I prefer.

gconftool-2 --set /desktop/gnome/url-handlers/https/command -t string 'opera -newpage %s'
gconftool-2 --set /desktop/gnome/url-handlers/http/command -t string 'opera -newpage %s'

other possibilities are:
-newwindow--------open url in new window
-newpage----------open url in new page (tab)
-backgroundpage---open url in background page (tab)
-fullscreen---------start in full screen mode
and others for addressing specific tabs.

thanks again
cheers :)

All times are GMT -5. The time now is 09:17 PM.