LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-09-2009, 08:42 AM   #1
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 684

Rep: Reputation: 34
Evolution imap : problem sending mail


Don't know how hard it can be to set an imap-account but anyway I'm having issues.
I am able to receive emails and I can see them in my inbox. But when I reply to a received email, the message is never fully send.

"Sending message (100% complete)"
but the message is still in the 'outbox'-folder and is not received by the receiving party.

I am using plain authentication... no ssl or tls to receive mail. Same conditions for outgoing mail.

Server type : smtp
server : mail.server.tld
server requires authentication
no encryption
authentication type : login/plain both not working
(check for supported types takes forever)

Does anyone know how to debug ?!
 
Old 10-12-2009, 05:57 PM   #2
HasC
Member
 
Registered: Oct 2009
Location: South America - Paraguay
Distribution: Debian 5 - Slackware 13.1 - Arch - Some others linuxes/*BSDs through KVM and Xen
Posts: 329

Rep: Reputation: 55
If I'm not wrong, you don't use IMAP(s) for *sending* mail, you use it for *getting* mail.

Talking about mail, "getting" and "sending" are two separate beasts.

For the "sending" part, you should use plain SMTP, or encrypted SMTP; and for the "getting" part, you use POP, IMAP, or the encrypted versions of the former two.

So, you should check the SMTP part, not the IMAP part. Perhaps setting the right address and port to connect

As an example: to use Gmail, you must set the SMTP server adress as "smtp.gmail.com:587" and set "TLS" too. I had a google a little to find this.

Other thing you can try: "telnet mail.server.tld 25", and send some SMTP raw text, and see if it responds. That way you can be sure the mail server is really up and running.

Last edited by HasC; 10-12-2009 at 06:01 PM.
 
Old 10-13-2009, 03:32 AM   #3
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 684

Original Poster
Rep: Reputation: 34
My hosting provider says :

incoming mail server: mail.domain.tld
incoming mail server: (SSL) x37.alfaservers.com
outgoing E-mail Server: mail.domain.tld (server requires authentication) port 587
outgoing E-mail Server: (SSL) x37.alfaservers.com (server requires authentication) port 465

So for outgoing mail I have :

server type : smtp (of course not imap)
server : x37.alfaservers.com:465
user secure connection : ssl
authentication type : login

When sending a mail :

Code:
Error while performing operation.
Could not connect to x37.alfaservers.com: Input/output error
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
sending mail from win xp to linux imap mail server cvdsamy Red Hat 2 05-30-2009 12:37 AM
Evolution sending mail to outbox bdaedalus359 Linux - Software 3 11-03-2008 10:05 AM
[SOLVED] Sending mail on evolution yaarappa Linux - Newbie 2 08-13-2008 03:31 PM
Mail sending problem from evolution ANU16 Linux - Software 1 04-30-2006 07:29 AM
Mail sending problem on Evolution flubber Linux - Software 3 05-03-2004 03:07 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration