LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Evolution, connector on Debian (https://www.linuxquestions.org/questions/linux-software-2/evolution-connector-on-debian-49846/)

Penrich 03-14-2003 02:55 PM

Evolution, connector on Debian
 
Got Debian installed at work (woot!) and now trying to get Ximian Evolution connecting to the Microsoft exchange server.

The story so far:

Installed Woody, then upgraded to Sid
Downloaded red carpet - says my system is not supported (Woody should be, not sure why Sid isn't?)
Downloaded ximian connector.deb file, try installing with dpkg -i ximian-connector_1.2.2-1.ximian.1_i386.deb
Had some dependenices problems I sorted out.
Got as far as ximian-connector depends on libsoup3 (>= 0.7.11); however: Version of libsoup3 on system is 0.7.10-3.
apt-get has problems upgrading soup, so I d/l the .7.11 tarball and install from source. Seems to work fine.
run ldconfig to update libraries

Now, when I try the dpkg command again, I get the same error - libsoup3 is the wrong version. I assumed I just needed to change a symlink in /usr/lib or somewhere, but this is all I could find...
Code:

lrwxrwxrwx    1 root    root          23 Mar 12 12:08 libsoup-apache.so.3 -> libsoup-apache.so.3.3.4
-rw-r--r--    1 root    root        2892 Jan 26 02:58 libsoup-apache.so.3.3.4
lrwxrwxrwx    1 root    root          16 Mar 12 12:08 libsoup.so.3 -> libsoup.so.3.3.4
-rw-r--r--    1 root    root      133168 Jan 26 02:58 libsoup.so.3.3.4

So, now I'm stuck! How do I tell my system that I have libsoup3-0.7.11, and where is it?

(Note also tried apt-get install red-carpet, and ximian-connector, but got same problems there).

Penrich 03-18-2003 08:47 PM

Give my own answer again - has to be Woody! Worked fine on a fresh install.


All times are GMT -5. The time now is 07:26 AM.