-   Linux - Software (
-   -   Evolution can't find libs in its own subdirectories (

slackist 03-15-2005 08:49 AM

Evolution can't find libs in its own subdirectories
Trying to install evolution I have downloaded and compiled the files listed here and compiled them all relatively painlessly (just a couple of glitches with that old chestnut PKG_CONFIG_PATH) but when I try to start evolution I get

mark@darkstar:/usr/local/bin# evolution-2.0
evolution-2.0: error while loading shared libraries: cannot open shared object file: No such file or directory


root@darkstar:/usr/local/bin# slocate

Also if I do ldd evolution-2.0 it shows a bunch of lib*.*.* => not found errors but all the libs reported as not found are present in evolution-2.0 sub-directories.

Thanks in advance for any ideas on how to get evolution to find its libs :)

Oliv' 03-16-2005 08:58 AM


A temporary solution (i.e. you have to do that each time you want to run evolution from a new shell):

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib/evolution/2.0
A definitive solution: add the following line in your /etc/ file:
and then run (as root) ldconfig


slackist 03-16-2005 10:33 AM

Thanks so much for the reply Oliv' but unfortunately it didn't work.

Same error message and I also played around with the $ sign and adding a "/" at the end.

I am totally stumped with this one :(

Oliv' 03-16-2005 10:49 AM

have you tried the solution with and ldconfig???

All times are GMT -5. The time now is 11:35 PM.