LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   /etc disappeared (https://www.linuxquestions.org/questions/linux-software-2/etc-disappeared-290111/)

Fonk 02-14-2005 11:57 AM

/etc disappeared
 
Hello,

I'm using Debian Sarge with Kernel 2.6.9.
Yesterday I used my Computer just for MP3-Playing for a few hours and installed the OpenOffice-Helpfiles in German and English with apt-get. Later I shut it down cleanly in the evening. As I booted it today afternoon it told me: "No inittab - Enter runlevel:" but no runlevel worked! As I could see with a Windows Tool my whole /etc directory is empty - there are only two files left from gftp: gftprc and bookmarks! I scanned the partition with a very good recoverytool under windows but none of the files in /etc could be found! So has anyone an idea how to get the files back? I can't start the computer without the init-scripts and chkfs the filesystem in another system is hardly possible because of a RAID 5 System with some Disks...

Thanks for any hint

twantrd 02-14-2005 01:16 PM

Wow, that's pretty crazy. Do a 'find' for passwd or shadow and see where it lives on your machine. If it doesn't, then I guess your /etc/* got wiped out for some odd reason. Post back the results, I'm curious what happened.

-twantrd

Fonk 02-14-2005 02:10 PM

Because of the RAID-Controller I can't access the volume without a compiled driver - so I have to use Windows and explore2fs. Neither passwd nor shadow can be found by explore2fs or my HDD Restore Utility... I also think that it's a very strange behaviour. My only explanation is that the apt-get for the OpenOffice-Helpfiles erased /etc as I have (or had) unstables in my apt-get sources!

Does anyone know a tool which can write to ext3 under Windows so I can copy /etc from another system? This should work, hm?

uman 02-14-2005 02:34 PM

You don't need to do it from Windows. Boot from one of the many freely available emergency rescue CDs, mount the drive with your other system (or a CD with the data on it) and copy away.

Cheers,

~uman

Fonk 02-14-2005 02:41 PM

The Problem is that the rescue CD's don't have the driver for my RAID Controller as it is not even in the 2.6.9 Kernel... it is an Highpoint Rocket RAID 454! So I had to compile the driver for exactly the Kernel running on the rescue CD - but I have no system to compile and usually the rescue CD's don't distribute the Kernel-Source, right? Or does anyone know such a rescue CD?

twantrd 02-14-2005 09:53 PM

Ahh those damn drivers. Give knoppix a try, it might be able to recognize the hardware. If it does, you're in good shape.

-twantrd

Fonk 02-15-2005 01:50 AM

Yes - I tried Knoppix but no chance... and Knoppix also bringt not the required sources to kompile the driver... :-(

sparc86 11-18-2008 05:34 PM

After almost 4 years, maybe you could try building a customized CD with your specific RAID modules, then I *suppose* it should works.


All times are GMT -5. The time now is 07:28 AM.