LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-27-2008, 08:33 AM   #1
oussama
LQ Newbie
 
Registered: Dec 2005
Posts: 18

Rep: Reputation: 0
Unhappy errors while building glibc-2.7


Hello!

I am trying to build glibc-2.7 but it fails to make, I am building it with the glibc-libidn-2.7 addon.

wehen I type "make" I got following error at the end:
Code:
...............
a - login/getutmpx.os
a - login/getutmp.os
a - elf/dl-iteratephdr.os
a - elf/dl-addr.os
a - elf/dl-profstub.os
a - elf/dl-libc.os
a - elf/dl-sym.os
a - elf/dl-tsd.os
a - elf/dl-vdso.os
ranlib /media/sda1/usr/src/glibc-build/libc_pic.a
gcc   -nostdlib -nostartfiles -r -o /media/sda1/usr/src/glibc-build/elf/librtld.map.o '-Wl,-(' /media/sda1/usr/src/glibc-build/elf/dl-allobjs.os /media/sda1/usr/src/glibc-build/libc_pic.a -lgcc '-Wl,-)' -Wl,-Map,/media/sda1/usr/src/glibc-build/elf/librtld.mapT
/media/sda1/usr/src/glibc-build/libc_pic.a(init-first.os):(.data+0x0): multiple definition of `__libc_multiple_libcs'
/media/sda1/usr/src/glibc-build/elf/dl-allobjs.os:/media/sda1/usr/src/glibc-2.7/elf/rtld.c:644: first defined here
/media/sda1/usr/src/glibc-build/libc_pic.a(dl-addr.os): In function `_dl_addr_inside_object':
/media/sda1/usr/src/glibc-2.7/elf/dl-addr.c:157: multiple definition of `_dl_addr_inside_object'
/media/sda1/usr/src/glibc-build/elf/dl-allobjs.os:/media/sda1/usr/src/glibc-2.7/elf/dl-open.c:699: first defined here
collect2: ld returned 1 exit status
make[2]: *** [/media/sda1/usr/src/glibc-build/elf/librtld.map] Error 1
make[2]: Leaving directory `/media/sda1/usr/src/glibc-2.7/elf'
make[1]: *** [elf/subdir_lib] Error 2
make[1]: Leaving directory `/media/sda1/usr/src/glibc-2.7'
make: *** [all] Error 2
when I type "make test", I got the following error:
Code:
...........................
	 gcc -std=gnu99 -fgnu89-inline -O2 -Wall -Winline -Wwrite-strings -fmerge-all-constants -g -Wstrict-prototypes      -Iinclude  -I/media/sda1/usr/src/glibc-build -Isysdeps/x86_64/elf -Inptl/sysdeps/unix/sysv/linux/x86_64 -Isysdeps/unix/sysv/linux/x86_64 -Isysdeps/unix/sysv/linux/wordsize-64 -Inptl/sysdeps/unix/sysv/linux -Inptl/sysdeps/pthread -Isysdeps/pthread -Isysdeps/unix/sysv/linux -Isysdeps/gnu -Isysdeps/unix/common -Isysdeps/unix/mman -Isysdeps/unix/inet -Inptl/sysdeps/unix/sysv -Isysdeps/unix/sysv -Isysdeps/unix/x86_64 -Inptl/sysdeps/unix -Isysdeps/unix -Isysdeps/posix -Isysdeps/x86_64/fpu -Inptl/sysdeps/x86_64 -Isysdeps/x86_64 -Isysdeps/wordsize-64 -Isysdeps/ieee754/ldbl-96 -Isysdeps/ieee754/dbl-64 -Isysdeps/ieee754/flt-32 -Isysdeps/ieee754 -Isysdeps/generic/elf -Isysdeps/generic -Inptl   -Ilibio -I. -I /lib/modules/2.6.24-19-generic/build/include -D_LIBC_REENTRANT -include include/libc-symbols.h       -E -DASSEMBLER tls.make.c \
	       -MD -MP -MT '$(common-objpfx)tls.make' -MF /media/sda1/usr/src/glibc-build/tls.make.dT \
	 | sed -n '/@@@/{s/@@@[	 ]*\(.*\)@@@/\1/;s/[	 ]*$//p;}'; \
	 echo 'common-generated += tls.make'; \
	 sed -e 's@ /media/sda1/usr/src/glibc-build/@ $(common-objpfx)@g' -e 's@^/media/sda1/usr/src/glibc-build/@$(common-objpfx)@g' -e 's@  *\([^ 	\/$][^ 	\]*\)@ $(..)\1@g' -e 's@^\([^ 	\/$][^ 	\]*\)@$(..)\1@g' /media/sda1/usr/src/glibc-build/tls.make.dT; \
	 rm -f /media/sda1/usr/src/glibc-build/tls.make.dT) > /media/sda1/usr/src/glibc-build/tls.makeT
mv -f /media/sda1/usr/src/glibc-build/tls.makeT /media/sda1/usr/src/glibc-build/tls.make
make[1]: Leaving directory `/media/sda1/usr/src/glibc-2.7'
make[1]: Entering directory `/media/sda1/usr/src/glibc-2.7'
make[1]: *** No rule to make target `test'.  Stop.
make[1]: Leaving directory `/media/sda1/usr/src/glibc-2.7'
make: *** [test] Error 2

when I type "make check", I got the following error:
Code:
.............................
    -I../include -I/media/sda1/usr/src/glibc-build/csu -I/media/sda1/usr/src/glibc-build -I../sysdeps/x86_64/elf -I../nptl/sysdeps/unix/sysv/linux/x86_64 -I../sysdeps/unix/sysv/linux/x86_64 -I../sysdeps/unix/sysv/linux/wordsize-64 -I../nptl/sysdeps/unix/sysv/linux -I../nptl/sysdeps/pthread -I../sysdeps/pthread -I../sysdeps/unix/sysv/linux -I../sysdeps/gnu -I../sysdeps/unix/common -I../sysdeps/unix/mman -I../sysdeps/unix/inet -I../nptl/sysdeps/unix/sysv -I../sysdeps/unix/sysv -I../sysdeps/unix/x86_64 -I../nptl/sysdeps/unix -I../sysdeps/unix -I../sysdeps/posix -I../sysdeps/x86_64/fpu -I../nptl/sysdeps/x86_64 -I../sysdeps/x86_64 -I../sysdeps/wordsize-64 -I../sysdeps/ieee754/ldbl-96 -I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754/flt-32 -I../sysdeps/ieee754 -I../sysdeps/generic/elf -I../sysdeps/generic -I../nptl  -I.. -I../libio -I. -I /lib/modules/2.6.24-19-generic/build/include -D_LIBC_REENTRANT -include ../include/libc-symbols.h       -DHAVE_INITFINI -o /media/sda1/usr/src/glibc-build/csu/hp-timing.o -MD -MP -MF /media/sda1/usr/src/glibc-build/csu/hp-timing.o.dt -MT /media/sda1/usr/src/glibc-build/csu/hp-timing.o
echo 'csu/init-first.o csu/libc-start.o csu/sysdep.o csu/version.o csu/check_fds.o csu/libc-tls.o csu/elf-init.o csu/dso_handle.o csu/errno.o csu/errno-loc.o csu/hp-timing.o' > /media/sda1/usr/src/glibc-build/csu/stamp.oT
mv -f /media/sda1/usr/src/glibc-build/csu/stamp.oT /media/sda1/usr/src/glibc-build/csu/stamp.o
make[2]: *** No rule to make target `/media/sda1/usr/src/glibc-build/iconv/stamp.o', needed by `/media/sda1/usr/src/glibc-build/libc.a'.  Stop.
make[2]: Leaving directory `/media/sda1/usr/src/glibc-2.7/csu'
make[1]: *** [csu/tests] Error 2
make[1]: Leaving directory `/media/sda1/usr/src/glibc-2.7'
make: *** [check] Error 2



I configured glibc by typing:
Code:
 ../glibc-2.7/configure --enable-add-ons --prefix=/usr
the source code is in /media/sda1/usr/src and not in /usr/src, becouse I am trying to build a minimal linux system (http://axiom.anu.edu.au/~okeefe/p2b/...uildMin-6.html)


some information about my system :
Code:
$ uname -a
Linux mir-desktop 2.6.24-19-generic #1 SMP Wed Jun 18 14:15:37 UTC 2008 x86_64 GNU/Linux
it is a new installed Xubuntu 8.04 (64bit)


May the problem has something with ranlib???

or may that has something with the glibc-libidn-2.7 addon??


How to solve the problem??, please help

I am not an experienced devloper

Last edited by oussama; 07-27-2008 at 08:35 AM. Reason: added more information
 
Old 07-27-2008, 08:45 AM   #2
pinniped
Senior Member
 
Registered: May 2008
Location: planet earth
Distribution: Debian
Posts: 1,732

Rep: Reputation: 50
There is some switch you need to specify to build the lib as 32-bit or as 64-bit. I think it's DISABLE-MULTIARCH. I don't have a copy of the source with me; read the config and installation files for clues or try "./configure --help".
 
Old 07-27-2008, 08:46 AM   #3
oussama
LQ Newbie
 
Registered: Dec 2005
Posts: 18

Original Poster
Rep: Reputation: 0
Thank you for your answer,
I will try that, an report what happen..
 
Old 07-27-2008, 10:06 AM   #4
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 55
It is a really long time ago that I built a LFS system guided by the book.
The current is here:
http://www.linuxfromscratch.org/lfs/view/stable/
They seem to go another way.
http://www.linuxfromscratch.org/lfs/...r06/glibc.html
Instead of:
../glibc-2.7/configure --enable-add-ons --prefix=/usr
they copy the glibc-libidn addon into the glibc source tree and then build it - without explicitly saying "--enable-addons"
If I look here:
http://www.linuxfromscratch.org/lfs/...r05/glibc.html
I get the impression that "--enable-addons" serves a different purpose than building the libidn addon...
They say:
Quote:
--enable-add-ons
This tells Glibc to use the NPTL add-on as its threading library
Maybe this helps?
 
Old 07-27-2008, 05:01 PM   #5
oussama
LQ Newbie
 
Registered: Dec 2005
Posts: 18

Original Poster
Rep: Reputation: 0
thank you Jomen
I tried:
../glibc-2.7/configure --prefix=/usr

but the result was the same error...

I will now try:
../glibc-2.7/configure --prefix=/usr --build=x86_64-linux-gnu --host=x86_64-linux-gnu
as Pinniped adviced me

I will report later what happen....
 
Old 07-27-2008, 05:12 PM   #6
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 55
I was not getting at the error you got - I was rather suggesting that your way of building glibc with glibc-libidn-2.7 addon
by way of configuring glibc with the --enable-add-ons flag might not be the way to achieve this.

From the LFS-Book I get the impression that the --enable-add-ons flag is for this: This tells Glibc to use the NPTL add-on as its threading library

You wanted to build it with glibc-libidn addon.
I saw that this is done differently in the LFS-Book - by copying/moving the extra source for glibc-libidn addon into the glibc source tree before building.

See the links above.
 
Old 07-27-2008, 05:32 PM   #7
oussama
LQ Newbie
 
Registered: Dec 2005
Posts: 18

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jomen View Post
I was not getting at the error you got - I was rather suggesting that your way of building glibc with glibc-libidn-2.7 addon
by way of configuring glibc with the --enable-add-ons flag might not be the way to achieve this.

From the LFS-Book I get the impression that the --enable-add-ons flag is for this: This tells Glibc to use the NPTL add-on as its threading library

You wanted to build it with glibc-libidn addon.
I saw that this is done differently in the LFS-Book - by copying/moving the extra source for glibc-libidn addon into the glibc source tree before building.

See the links above.
OK now I understand what you meen, thanks

I did like in the LFS-book, I copied the glibc-libidn addon into the glibc source before building
 
Old 07-27-2008, 06:11 PM   #8
oussama
LQ Newbie
 
Registered: Dec 2005
Posts: 18

Original Poster
Rep: Reputation: 0
Unhappy

Hello again,
I tried again with:
Code:
../glibc-2.7/configure --prefix=/usr --build=x86_64-linux-gnu --host=x86_64-linux-gnu
and the same error appears...

Please help!
 
Old 07-28-2008, 03:17 AM   #9
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 55
An example of how others do it might be of help - so I'm posting how Gentoo configures its glibc before build.
This is from the build-log for my glibc-2.7 - since June I'm using glibc-2.8.

It looks different to yours - a lot more options are passed - some of them not strictly needed probably.
Judge for yourself where you might have forgotten something by comparing that to your configuration:

Code:
Configuring GLIBC for nptl with:
                --disable-stackguard-randomization
                --enable-old-ssp-compat
                --enable-omitfp
                --enable-add-ons=nptl,c_stubs,libidn,ports
                --enable-kernel=2.6.9
                --without-selinux
                --without-cvs
                --enable-bind-now
                --build=i686-pc-linux-gnu
                --host=i686-pc-linux-gnu
                --disable-profile
                --with-gd
                --with-headers=/usr/include
                --prefix=/usr
                --libdir=/usr/lib
                --mandir=/usr/share/man
                --infodir=/usr/share/info
                --libexecdir=/usr/lib/misc/glibc
and of course a lot of patches where applied - not sure wether Gentoo specific or needed for the build notto break.

Last edited by jomen; 07-28-2008 at 03:21 AM.
 
Old 07-28-2008, 05:44 AM   #10
pinniped
Senior Member
 
Registered: May 2008
Location: planet earth
Distribution: Debian
Posts: 1,732

Rep: Reputation: 50
Quote:
Originally Posted by oussama View Post
Hello again,
I tried again with:
Code:
../glibc-2.7/configure --prefix=/usr --build=x86_64-linux-gnu --host=x86_64-linux-gnu
and the same error appears...

Please help!
Unfortunately the 'build' and 'host' settings don't really help; you need to disable the 'multiarch' thing. Since you're 'host' is also x86_64, you can leave out the 'build' and 'host'; the config scripts will set them all to your current system (x86_64).
 
Old 07-28-2008, 12:03 PM   #11
oussama
LQ Newbie
 
Registered: Dec 2005
Posts: 18

Original Poster
Rep: Reputation: 0
Thank you jomen!
I will try with these arguments, and report the result.

Thank you pinniped!
I will try to find some method to disable the 'multiarch', HELP me someone if you know HOW.


Please anyone, help if you know the solution!
 
Old 07-28-2008, 05:57 PM   #12
oussama
LQ Newbie
 
Registered: Dec 2005
Posts: 18

Original Poster
Rep: Reputation: 0
Unhappy

Oh!! no better result, exactly the same error appears again...
I tried the following arguments (I have tried this time without libidn to avoid extra problems):
../glibc-2.7/configure --disable-stackguard-randomization --enable-old-ssp-compat --enable-omitfp --enable-add-ons=nptl --enable-kernel=linux-2.6.26 --without-selinux --without-cvs --enable-bind-now --build=x86_64-linux-gnu --host=x86_64-linux-gnu --disable-profile --with-gd --with-headers=/media/sda1/usr/src/linux-2.6.26/include --prefix=/usr --libdir=/usr/lib --mandir=/usr/share/man --infodir=/usr/share/info --libexecdir=/usr/lib/misc/glibc


Please someone who can help....
 
Old 07-30-2008, 05:45 AM   #13
oussama
LQ Newbie
 
Registered: Dec 2005
Posts: 18

Original Poster
Rep: Reputation: 0
Please somone who can help!!
 
Old 07-31-2008, 06:39 PM   #14
oussama
LQ Newbie
 
Registered: Dec 2005
Posts: 18

Original Poster
Rep: Reputation: 0
Thumbs up errors while building glibc-2.7 - solved!!

WOW, thanks God, I found a solution, thanks for Vinu in Glibc help list who give me an answer:
http://sourceware.org/ml/libc-help/2.../msg00075.html

thanks for all you, pinniped & jomen who tried to help me
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems building glibc-2.5 sorenp Slackware 6 10-12-2007 03:13 AM
Building glibc-2.5 Error chiefsmurph Linux - Software 7 04-28-2007 12:00 AM
Building glibc for i686 on RHEL-4 cardiffandvale Linux - Software 0 03-16-2007 12:09 PM
Question about building glibc and ncurses tomdkat Linux - Software 2 02-18-2005 10:59 AM
Problems building glibc-2.3.2 CodeRed Linux - Software 0 07-10-2003 09:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration