LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-13-2017, 07:41 PM   #1
starrfleat
Member
 
Registered: Nov 2012
Posts: 35

Rep: Reputation: Disabled
Errors Trying To Install Irridium-Browser on Linux 17.3


When attempting installation, I get this error:
Dependency is not satisfiable: libstdc++6 required, but 4.9 is to be installed. I find this cryptic, especially since version 4.8 of this is installed, so version 4.9 should work?
 
Old 07-13-2017, 08:22 PM   #2
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
Yeah 4.9 should work it's a C++ runtime library.

I think when a dependency is not satisfiable it's no longer used because it is old or not supported under 17.3 anymore.

To check on which version of libstdc is install run this:

Code:
dpkg -L libstdc
-:::-OR look in Synaptic to see what version is installed.-:::-

Once you know what version is installed, upgrade your 17.3 and reboot. Upgrading the os will upgrade pkg's that are old thus upgrading libstdc to the current I'd think.

Code:
apt-get update
Code:
apt-get dist-upgrade
If that fails than the only other thing you could try if you want; is to perform a fresh install of Linux Mint 18:-

Why not try Chromium?

https://www.google.com/search?q=libs...o+be+installed
 
Old 07-13-2017, 09:13 PM   #3
starrfleat
Member
 
Registered: Nov 2012
Posts: 35

Original Poster
Rep: Reputation: Disabled
4.8 is installed, per synaptic.
I just wanted to see what iridium was like. I'm using vivaldi most of the time lately.
Perhaps in time I'll try 18. Have to set aside time, etc. Maybe after I receive my new external drive, and get everything backed up.
 
Old 07-13-2017, 09:47 PM   #4
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
Quote:
Originally Posted by starrfleat View Post
4.8 is installed, per synaptic.
I just wanted to see what iridium was like. I'm using vivaldi most of the time lately.
Perhaps in time I'll try 18. Have to set aside time, etc. Maybe after I receive my new external drive, and get everything backed up.
If it's not to much hassle remove 4.8 and install 4.9:-

I've never tried Vivaldi. How's it run?

If you just want to try Iridium just install a Virtual Machine and give it a spin. That way you'll have a peek while your waiting for your external to arrive. Performing backups are not on my preferred list. lol

I think you will like LM 18. Here's a review.
https://arstechnica.com/information-...ter-than-this/

http://www.zdnet.com/article/linux-m...-look-out-for/
 
Old 07-17-2017, 04:18 PM   #5
Mike_Walsh
Member
 
Registered: Jul 2017
Location: King's Lynn, UK
Distribution: Nowt but Puppies....
Posts: 530

Rep: Reputation: 284Reputation: 284Reputation: 284
I've been messing around with these Chromium-based browsers for years.

Generally speaking, you will find this error appearing as newer versions of the browser are released, since they're compiled under successively newer versions of the glibc. And even if you upgrade the libstdc++ dependency, the very next error you'll get in the terminal will be that it wants a newer version of the glibc itself.

This is not something that's easy to do. A given release of any particular distro is usually built around a specific version of the glibc; almost everything will call upon it at some point or another. To upgrade that usually entails virtually rebuilding your distro from the ground up. And that's a major undertaking.....even for the experts.

Curiously, Google themselves (who sponsor the Chromium project - which is where all of these browsers get their source code), when they create Chrome, re-compile it against a very much older version of the glibc.....to ensure it's available to the largest possible user base. They recognise that not everyone is going to be running the very latest, up-to-date, cutting-edge distro.....with all the newest kernels, dependencies & libs.

I concur with Ztcoracat. Try it in a VM, if you're that interested. TBH, with all the Chromium-based browsers, with the exception of cosmetic differences (especially so with Vivaldi..!), once you've seen one, you've seen 'em all.


Mike.

Last edited by Mike_Walsh; 07-17-2017 at 05:38 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
nmbd master browser messages, are these errors or benign? anon091 Linux - Server 4 01-19-2015 08:42 AM
Can't install chromium-browser.tcz from App Browser in Tinycore-5.3-19 M.Tenenbaum Linux - Newbie 1 06-05-2014 11:18 AM
PHP5 will not display errors to the browser in Ubuntu mrbass21 Linux - Server 4 02-15-2011 06:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration