LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   errors compiling gcc 4.2.1 (https://www.linuxquestions.org/questions/linux-software-2/errors-compiling-gcc-4-2-1-a-621659/)

bio71 02-16-2008 03:05 PM

errors compiling gcc 4.2.1
 
Hello,

I have tried to compile gcc and I get the following error. "i686-suse-linux-ar command not found. I have also tried this under cygwin and get the same error. "i686-pc-cygwin-ar command not found. I am not sure if configure completes incorrectly or this is a problem with make. Configure checks for ar and reports ar is just ar and not i686-pc-cygwin-ar. Do I have to look at the makefile or configure?

j-ray 02-17-2008 03:00 AM

seems ar is not in your $PATH. Maybe it is installed in /usr/local/bin? you could set a symlink then to /usr/bin
sudo ln -s /usr/local/bin/ar /usr/bin/ar

but maybe it is not installed at all. Anyway it would be useful to know which distribution you run.

bio71 02-17-2008 04:04 PM

I run Cygwin and SuSE Linux 10. I get the same error with both distros. My ar is located in /usr/bin and it's in my $PATH. Should I bother the maintainers of gcc?


All times are GMT -5. The time now is 05:57 PM.