LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-19-2016, 12:39 PM   #1
siery
Member
 
Registered: Dec 2015
Posts: 34

Rep: Reputation: Disabled
Error: X11 support requires Xcursor library when i already install Xcursor!


Hello!

I have problem with building Allegro 5 on Debian Jessie. I solve already some dependences problem and now I'm getting error:
Code:
CMake Error at CMakeLists.txt:570 (message):
  X11 support requires Xcursor library.
I have already installed libxcursor1 package but I'm still getting this error.
My CMake generator is "Unix Makefiles".

Thanks, Siery.
 
Old 01-19-2016, 03:43 PM   #2
Keith Hedger
Senior Member
 
Registered: Jun 2010
Location: Wiltshire, UK
Distribution: Linux From Scratch, Slackware64, Partedmagic
Posts: 2,875

Rep: Reputation: 746Reputation: 746Reputation: 746Reputation: 746Reputation: 746Reputation: 746Reputation: 746
You need to install the relevent -dev packages as debian's apt splits packages into the lib/application files, the development files and the documentation files.
 
Old 01-19-2016, 05:38 PM   #3
siery
Member
 
Registered: Dec 2015
Posts: 34

Original Poster
Rep: Reputation: Disabled
I did. I'm sorry i didn't mention that. I install all packages i find:

Code:
libxcursor-dev - X cursor management library (development files)
libxcursor1 - X cursor management library
libxcursor1-dbg - X cursor management library (unstripped)
libxcb-cursor-dev - utility libraries for X C Binding -- cursor, development files
libxcb-cursor0

Last edited by siery; 01-19-2016 at 05:48 PM.
 
Old 01-21-2016, 10:50 AM   #4
siery
Member
 
Registered: Dec 2015
Posts: 34

Original Poster
Rep: Reputation: Disabled
I fix the problem by deleting CMakeCache.txt. It has been improperly cached.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
X11 Xcursor theme without KDE/Gnome cvelasquez Linux - Desktop 4 03-24-2009 08:09 AM
XCursor - install-sh missing DoddyUK Linux - Software 0 01-27-2005 06:07 PM
Change Xcursor themes? paul_linux_user Fedora 1 02-03-2004 07:02 PM
changing XCursor themes on the fly? akira_baka Linux - Software 3 05-10-2003 02:59 AM
Can't use XCursor themes. gbrad Linux - Software 3 05-01-2003 12:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration