LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Error while compiling TrueCrypt on CentOS: error: Can't use --enable-std_string... (https://www.linuxquestions.org/questions/linux-software-2/error-while-compiling-truecrypt-on-centos-error-cant-use-enable-std_string-654618/)

displacedtexan 07-09-2008 11:26 AM

Error while compiling TrueCrypt on CentOS: error: Can't use --enable-std_string...
 
So, I am trying to install TrueCrypt on my CentOS 5.1 64 bit box. I believe I have all the requirements listed in the Readme.txt:

"Requirements for Building TrueCrypt for Linux and Mac OS X:
-----------------------------------------------------------

- GNU Make
- GNU C++ Compiler 4.0 or compatible
- Apple XCode (Mac OS X only)
- pkg-config
- wxWidgets 2.8 library source code (available at http://www.wxwidgets.org)
- FUSE library (available at http://fuse.sourceforge.net and
http://code.google.com/p/macfuse)"

I get the following error:

Code:

[root@aria truecrypt-6.0a-source]# make WX_ROOT=/home/mythtv/wxGTK-2.8.8 wxbuild
Configuring wxWidgets library...
configure: error: Can't use --enable-std_string without std::wstring or std::bas
ic_string<wchar_t>
make: *** [wxbuild] Error 1

Any idea how I proceed?

Thanks!!

Micro420 07-24-2008 03:17 PM

I saw your same post on the Truecrypt forum. Here is what someone responded in case you missed it on the Truecrypt forum:
Quote:

For whatever reason, I didn't have libstd installed...

I eventually got TrueCrypt installed on CentOS 64-bit... although I had yum install a lot of dependencies. I had to run: pkg-config gtk+-2.0 --libs and check what was missing then install via yum and repeat.

I eventually got everything, and now it works!! Much easier to install on 32 bit CentOS (didn't have all the dependency issues).


All times are GMT -5. The time now is 09:50 AM.