LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-09-2008, 11:26 AM   #1
displacedtexan
LQ Newbie
 
Registered: May 2007
Posts: 22

Rep: Reputation: 15
Error while compiling TrueCrypt on CentOS: error: Can't use --enable-std_string...


So, I am trying to install TrueCrypt on my CentOS 5.1 64 bit box. I believe I have all the requirements listed in the Readme.txt:

"Requirements for Building TrueCrypt for Linux and Mac OS X:
-----------------------------------------------------------

- GNU Make
- GNU C++ Compiler 4.0 or compatible
- Apple XCode (Mac OS X only)
- pkg-config
- wxWidgets 2.8 library source code (available at http://www.wxwidgets.org)
- FUSE library (available at http://fuse.sourceforge.net and
http://code.google.com/p/macfuse)"

I get the following error:

Code:
[root@aria truecrypt-6.0a-source]# make WX_ROOT=/home/mythtv/wxGTK-2.8.8 wxbuild
Configuring wxWidgets library...
configure: error: Can't use --enable-std_string without std::wstring or std::bas
ic_string<wchar_t>
make: *** [wxbuild] Error 1
Any idea how I proceed?

Thanks!!
 
Old 07-24-2008, 03:17 PM   #2
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
I saw your same post on the Truecrypt forum. Here is what someone responded in case you missed it on the Truecrypt forum:
Quote:
For whatever reason, I didn't have libstd installed...

I eventually got TrueCrypt installed on CentOS 64-bit... although I had yum install a lot of dependencies. I had to run: pkg-config gtk+-2.0 --libs and check what was missing then install via yum and repeat.

I eventually got everything, and now it works!! Much easier to install on 32 bit CentOS (didn't have all the dependency issues).

Last edited by Micro420; 07-24-2008 at 03:42 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 9: error when compiling flash plug-in with error failed dependencies seow_ming Fedora 2 06-17-2008 08:17 PM
Error when compiling kernel linux-2.6.22 : make: ***[_modinst_post] Error 137 ngoclan.it Linux - General 1 12-11-2007 07:54 AM
Error when compiling kernel linux-2.6.22 : make: ***[_modinst_post] Error 137 ngoclan.it Linux - Newbie 0 12-11-2007 07:49 AM
i get an error ./term.c :95 error conflicting types of tpam when compiling bitchx eveningblush Programming 0 03-30-2006 07:46 AM
Error compiling php 5.1 and also a fantastico error arachn1d Linux - Software 0 02-19-2006 05:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration