LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-24-2017, 08:29 AM   #1
juanr-mn
LQ Newbie
 
Registered: Jun 2017
Posts: 2

Rep: Reputation: Disabled
error starting service - libstdc++ version problem


Hello - I've installed Ubiquiti Unifi-Video service on Linux Mint:

Distributor ID: LinuxMint
Description: Linux Mint 17.3 Rosa
Release: 17.3
Codename: rosa

$ uname -r 3.19.0-32-generic

The problem occurred after the recent Linux kernel update broke the unifi-video working install - I uninstalled and reinstalled the unifi-video service not knowing the kernel was at fault - Ubiquiti has since sent out a fix for the kernel problems, however, I am left with the following error:
-------- ------------
Error Starting Service

/usr/lib/unifi-video/lib/libubnt_webrtc_jni.so:/usr/lib/x86_64-linux-gnu/libstdc++.so.6: version 'GLIBCXX_3.4.20' not found(required by /usr/lib/unifi-video/lib/libubnt_webrtc_jni)
-------- -----------

To try to fix this I've downloaded and placed the libstdc++.so.6.0.20 which I think has the correct GLIBCXX (replacing libstdc++.so.6.0.23) in the /usr/lib/x86_64-linux-gnu/ directory and I ran the following to update the symlink.

$ sudo ln -f -s libstdc++.so.6.0.20 libstdc++.so.6

Didn't work
Any tips or pointers appreciated!
j
 
Old 06-24-2017, 09:31 AM   #2
smallpond
Senior Member
 
Registered: Feb 2011
Location: Massachusetts, USA
Distribution: Fedora 33
Posts: 3,604

Rep: Reputation: 1031Reputation: 1031Reputation: 1031Reputation: 1031Reputation: 1031Reputation: 1031Reputation: 1031Reputation: 1031
Replacing any of the standard libraries will break all of the programs on your system that depend on the correct version. Put the library in an alternate location and launch the code that needs it after setting LD_LIBRARY_PATH.
 
Old 06-25-2017, 07:03 PM   #3
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1010Reputation: 1010Reputation: 1010Reputation: 1010Reputation: 1010Reputation: 1010Reputation: 1010Reputation: 1010
Your OS is getting old. You might consider upgrading.
 
Old 07-13-2017, 01:14 PM   #4
juanr-mn
LQ Newbie
 
Registered: Jun 2017
Posts: 2

Original Poster
Rep: Reputation: Disabled
Yes smallpond, changing that library caused me to learn how to recover a non-booting linux partition, among other things.

Thanks for your help!
j
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
openvpn error during starting the service saravanakumar Linux - Server 1 07-22-2011 10:06 AM
[SOLVED] Problem installing Firefox 5 - libstdc++.so.6: version 'GLIBCXX_3.4.9' not found newbieShannon Linux - Newbie 9 07-06-2011 06:43 PM
Skype runtime error: libstdc++.so.6: no version information billion Linux - Software 1 01-21-2008 11:43 AM
libstdc++.so version problem baosheng Fedora 2 05-07-2006 08:02 AM
libstdc++.so.5:version GLIBCPP_3.2 not found error RaviPrakash Linux - General 1 09-28-2005 01:28 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration