-   Linux - Software (
-   -   error: out of disk on loading linux.mod (

Breagha 03-10-2010 06:33 AM

error: out of disk on loading linux.mod
I'm not sure if this is a GRUB issue or a Ubuntu issue, so posting it here and hoping it's the right place.

I recently (ie, within the last few days) installed Ubuntu 9.10 64-bit on my system. When I rebooted, I got:

Grub loading...
error: out of disk

Searching on the error message, I found some different workarounds - commenting out "if [ -n \${have_grubenv} ]; then save_env recordfail; fi" in /etc/grub.d/10_linux, and uncommenting "GRUB_DISABLE_LINUX_UUID=true" in /etc/default/grub - but neither worked. Not on their own and not together.

Following the instructions here, I get the 'error: out of disk', when I try to load the linux.mod (insmod /boot/grub/linux.mod).

I downloaded the super grub disk, and that worked. I can load up my system using that, but simply copying the boot commands from that can't be the ideal solution, can it?

Any thoughts or ideas are greatly appeciated.

syg00 03-10-2010 07:11 AM

Did you run update-grub after those edits ?.
Does it work if you change the boot menu entries ?.

My suggestion would be to uninstall grub2, but that would probably just get me labelled a Luddite.

Breagha 03-10-2010 07:26 AM

I updated grub, yes.

No changes to the boot menu that I've made has worked. But the changes mostly consisted of what those two work arounds did. I have little to no knowledge about grub, so I'm a bit careful with experimenting.

I've previously run Ubuntu 9.10 32-bit with no trouble.

Breagha 03-11-2010 05:02 AM

Nobody got an idea as to what might be the problem?

Help out a linux/ grub newbie - save a kitten :P

All times are GMT -5. The time now is 04:35 AM.