LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-07-2011, 05:14 PM   #1
grant.smith
LQ Newbie
 
Registered: Jul 2009
Location: Calgary,AB, Canada
Posts: 10

Rep: Reputation: 0
error installing Usenext


Hi All,

I just installed Fedora 14.

One of the apps I would like to try out is usenext.

Selectint the download for the right version (Linux - Suse, Red Hat, Fedora) I get the rpm file.
Either opening this straight away or saving then opening it comes back with the following errors:


usenext-5.27-1.i386 requires mono(gdk-sharp) = 2.10.0.0
usenext-5.27-1.i386 requires unrar
usenext-5.27-1.i386 requires mono(glib-sharp) = 2.10.0.0
usenext-5.27-1.i386 requires mono(gtk-sharp) = 2.10.0.0


I take it these are dependancies?

Can I download them from anywhere?

Cheers!!

Grant
 
Old 02-08-2011, 04:39 AM   #2
prodev05
Member
 
Registered: Jul 2009
Location: Planet Earth
Distribution: Unix & Linux Variants
Posts: 304

Rep: Reputation: 20
Configure Fedora 14's repository. Then start installing the required package.
 
Old 02-08-2011, 09:17 PM   #3
grant.smith
LQ Newbie
 
Registered: Jul 2009
Location: Calgary,AB, Canada
Posts: 10

Original Poster
Rep: Reputation: 0
OK I installed unrar and the mono-core along with gtk-sharp2-2.12.10-3.fc14.i686.rpm.

This is what I get:

]#rpm -Uvih usenext.rpm
error: Failed dependencies:
mono(gdk-sharp) = 2.10.0.0 is needed by usenext-5.27-1.i386
mono(glib-sharp) = 2.10.0.0 is needed by usenext-5.27-1.i386
mono(gtk-sharp) = 2.10.0.0 is needed by usenext-5.27-1.i386
]# rpm -Uvih gtk-sharp2-2.12.10-3.fc14.i686.rpm
Preparing... ########################################### [100%]
package gtk-sharp2-2.12.10-3.fc14.i686 is already installed


Is 2.12 not backwards compatible with 2.10?

or do I need the exact version it's looking for, 2.10.0.0?
 
Old 02-09-2011, 12:07 AM   #4
prodev05
Member
 
Registered: Jul 2009
Location: Planet Earth
Distribution: Unix & Linux Variants
Posts: 304

Rep: Reputation: 20
Are you specific about the version? why don't you configure the repo and use the latest package.
 
Old 02-09-2011, 12:21 AM   #5
grant.smith
LQ Newbie
 
Registered: Jul 2009
Location: Calgary,AB, Canada
Posts: 10

Original Poster
Rep: Reputation: 0
Hmm..

Not sure how to. :|
 
Old 02-09-2011, 12:24 AM   #6
grant.smith
LQ Newbie
 
Registered: Jul 2009
Location: Calgary,AB, Canada
Posts: 10

Original Poster
Rep: Reputation: 0
sorry if I'm being a bit slow. Not had to go to this depth of linux before. (long overdue!!)

if you mean the yum, then it's already up and running.

this is wha tI get.:

yum install usenext
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Setting up Install Process
No package usenext available.
Error: Nothing to do
 
Old 02-09-2011, 03:17 AM   #7
prodev05
Member
 
Registered: Jul 2009
Location: Planet Earth
Distribution: Unix & Linux Variants
Posts: 304

Rep: Reputation: 20
Why I suggest you to get yum means, it will install all the dependencies by its own after your confirmation.

When you install the lower version, it might conflict with the existing package. Try "rpm -Uvh --test <your rpm pkg>" to see the conflicting package.

you can't install specific package which is conflicting with other dependencies.
 
Old 02-09-2011, 09:32 PM   #8
grant.smith
LQ Newbie
 
Registered: Jul 2009
Location: Calgary,AB, Canada
Posts: 10

Original Poster
Rep: Reputation: 0
Yum IS installed.

yum returns:

yum install usenext
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Setting up Install Process
No package usenext available.
Error: Nothing to do


your rpm test sugestion returns that same as I have been posting ealrier on.:

rpm -Uvh --test /home/gsm/Downloads/usenext.rpm
error: Failed dependencies:
mono(gdk-sharp) = 2.10.0.0 is needed by usenext-5.27-1.i386
mono(glib-sharp) = 2.10.0.0 is needed by usenext-5.27-1.i386
mono(gtk-sharp) = 2.10.0.0 is needed by usenext-5.27-1.i386






I'm back to the question, is the 2.12.12_3 that I installed too new?
 
Old 02-09-2011, 09:41 PM   #9
grant.smith
LQ Newbie
 
Registered: Jul 2009
Location: Calgary,AB, Canada
Posts: 10

Original Poster
Rep: Reputation: 0
I'm a step further. However it looks to me like the app is not yet supported on Fedora 14.

Thoughs anyone?

---------------------------------
yum install usenext.rpm
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Setting up Install Process
Examining usenext.rpm: usenext-5.27-1.i386
Marking usenext.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package usenext.i386 0:5.27-1 set to be installed
--> Processing Dependency: mono(gdk-sharp) = 2.10.0.0 for package: usenext-5.27-1.i386
--> Processing Dependency: mono(glib-sharp) = 2.10.0.0 for package: usenext-5.27-1.i386
--> Processing Dependency: mono(gtk-sharp) = 2.10.0.0 for package: usenext-5.27-1.i386
--> Finished Dependency Resolution
Error: Package: usenext-5.27-1.i386 (/usenext)
Requires: mono(glib-sharp) = 2.10.0.0
Installed: gtk-sharp2-2.12.10-3.fc14.i686 (@/gtk-sharp2-2.12.10-3.fc14.i686(2))
mono(glib-sharp) = 2.12.0.0
Available: banshee-community-extensions-1.8.0-2.fc14.i686 (fedora)
mono(glib-sharp) = 2.12.0.0
Available: clutter-sharp-0-0.8.20090828.fc14.i686 (fedora)
mono(glib-sharp) = 2.12.0.0
Error: Package: usenext-5.27-1.i386 (/usenext)
Requires: mono(gdk-sharp) = 2.10.0.0
Installed: gtk-sharp2-2.12.10-3.fc14.i686 (@/gtk-sharp2-2.12.10-3.fc14.i686(2))
mono(gdk-sharp) = 2.12.0.0
Error: Package: usenext-5.27-1.i386 (/usenext)
Requires: mono(gtk-sharp) = 2.10.0.0
Installed: gtk-sharp2-2.12.10-3.fc14.i686 (@/gtk-sharp2-2.12.10-3.fc14.i686(2))
mono(gtk-sharp) = 2.12.0.0
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Usenext Linux Client stehughes117 Linux - Software 8 06-30-2013 04:14 PM
error while installing unixODBC-2.2.14 on AIX 5.3 -configure: error: C compiler canno sriram_nittala AIX 0 01-20-2010 04:18 AM
UseNeXt download record: 674mb in 66 secs!! Hitboxx General 1 12-11-2007 01:36 AM
error when installing gift: error: cannot compute sizeof (short), 77 v1pEr Linux - Software 5 11-04-2004 03:43 AM
ERROR running make when installing Nvidia drivers (syntax error) randyriver10 Linux - Software 5 02-21-2004 05:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration