LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-21-2018, 02:11 PM   #1
tonj
Member
 
Registered: Sep 2008
Posts: 506

Rep: Reputation: 37
error installing ocamlfuse


I'm running centos 7 and trying to mount google-drive into my system with ocamlfuse using the instructions here:
https://www.2daygeek.com/mount-acces...lfuse-client/#

I followed the instructions in the centos 7 section but when I run yum install ocamlfuse.x86_64 I get package errors and it won't work. As you can see below it's a real mess so thanks if anyone can help.

here is the console output:

Quote:
# yum install ocamlfuse.x86_64
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: mirror.clustered.net
* epel: mirror.neostrada.nl
* extras: mirror.clustered.net
* updates: mirror.cwcs.co.uk
Resolving Dependencies
--> Running transaction check
---> Package ocamlfuse.x86_64 0:2.7.1-5.cvs5.el7.centos will be installed
--> Processing Dependency: ocaml(Array) = 8a6bb22925744456eb66180ea42e3344 for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Processing Dependency: ocaml(Callback) = 198fb4bcde892143b0866b03cfae8085 for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Processing Dependency: ocaml(Com) = e9acf00897cee519f5dd695dba38dc72 for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Processing Dependency: ocaml(Complex) = 1858860030310b043b5d7fcb362095a3 for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Processing Dependency: ocaml(Condition) = 7e8a9025f5f5369f8af64bb2d24f1bc5 for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Processing Dependency: ocaml(Hashtbl) = 024edc3512403b725052aec8e41ed971 for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Processing Dependency: ocaml(List) = d757117653d9319fefb7ddc78a998f41 for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Processing Dependency: ocaml(Mutex) = bf9c20efca54afdc260604f8bb20c0e9 for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Processing Dependency: ocaml(Pervasives) = 36b5bc8227dc9914c6d9fd9bdcfadb45 for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Processing Dependency: ocaml(String) = db7f34081ef8fcaf499f19523d0736c6 for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Processing Dependency: ocaml(Thread) = 9c6f664141b325633a43fee33cfc2f6d for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Processing Dependency: ocaml(Unix) = 93736a394d3d85d6d127fe238ddc6092 for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Processing Dependency: ocaml(runtime) = 4.01.1 for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Running transaction check
---> Package ocaml-camlidl.x86_64 0:1.05-34.el7.centos will be installed
--> Processing Dependency: ocaml(Callback) = 198fb4bcde892143b0866b03cfae8085 for package: ocaml-camlidl-1.05-34.el7.centos.x86_64
--> Processing Dependency: ocaml(Int32) = ad06f04cfca6d404d1de76c3dc67324a for package: ocaml-camlidl-1.05-34.el7.centos.x86_64
--> Processing Dependency: ocaml(Obj) = b0adfa4175f86e4394859886c1a374bb for package: ocaml-camlidl-1.05-34.el7.centos.x86_64
--> Processing Dependency: ocaml(Pervasives) = 36b5bc8227dc9914c6d9fd9bdcfadb45 for package: ocaml-camlidl-1.05-34.el7.centos.x86_64
--> Processing Dependency: ocaml(runtime) = 4.01.1 for package: ocaml-camlidl-1.05-34.el7.centos.x86_64
---> Package ocamlfuse.x86_64 0:2.7.1-5.cvs5.el7.centos will be installed
--> Processing Dependency: ocaml(Array) = 8a6bb22925744456eb66180ea42e3344 for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Processing Dependency: ocaml(Callback) = 198fb4bcde892143b0866b03cfae8085 for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Processing Dependency: ocaml(Complex) = 1858860030310b043b5d7fcb362095a3 for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Processing Dependency: ocaml(Condition) = 7e8a9025f5f5369f8af64bb2d24f1bc5 for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Processing Dependency: ocaml(Hashtbl) = 024edc3512403b725052aec8e41ed971 for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Processing Dependency: ocaml(List) = d757117653d9319fefb7ddc78a998f41 for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Processing Dependency: ocaml(Mutex) = bf9c20efca54afdc260604f8bb20c0e9 for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Processing Dependency: ocaml(Pervasives) = 36b5bc8227dc9914c6d9fd9bdcfadb45 for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Processing Dependency: ocaml(String) = db7f34081ef8fcaf499f19523d0736c6 for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Processing Dependency: ocaml(Thread) = 9c6f664141b325633a43fee33cfc2f6d for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Processing Dependency: ocaml(Unix) = 93736a394d3d85d6d127fe238ddc6092 for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
--> Processing Dependency: ocaml(runtime) = 4.01.1 for package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64
Error: Package: ocaml-camlidl-1.05-34.el7.centos.x86_64 (sergiomb-google-drive-ocamlfuse)
Requires: ocaml(runtime) = 4.01.1
Available: ocaml-runtime-4.05.0-6.el7.x86_64 (base)
ocaml(runtime) = 4.05.0
Error: Package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64 (sergiomb-google-drive-ocamlfuse)
Requires: ocaml(runtime) = 4.01.1
Available: ocaml-runtime-4.05.0-6.el7.x86_64 (base)
ocaml(runtime) = 4.05.0
Error: Package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64 (sergiomb-google-drive-ocamlfuse)
Requires: ocaml(Unix) = 93736a394d3d85d6d127fe238ddc6092
Available: ocaml-runtime-4.05.0-6.el7.x86_64 (base)
ocaml(Unix) = 5a9bdfb6a1907a5964517e3232eacb14
Error: Package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64 (sergiomb-google-drive-ocamlfuse)
Requires: ocaml(Complex) = 1858860030310b043b5d7fcb362095a3
Available: ocaml-runtime-4.05.0-6.el7.x86_64 (base)
ocaml(Complex) = 00bc897a3d9c3cee5614e7f191f89ab7
Error: Package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64 (sergiomb-google-drive-ocamlfuse)
Requires: ocaml(String) = db7f34081ef8fcaf499f19523d0736c6
Available: ocaml-runtime-4.05.0-6.el7.x86_64 (base)
ocaml(String) = 90043e0e1317e530d5640850963d44c0
Error: Package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64 (sergiomb-google-drive-ocamlfuse)
Requires: ocaml(Hashtbl) = 024edc3512403b725052aec8e41ed971
Available: ocaml-runtime-4.05.0-6.el7.x86_64 (base)
ocaml(Hashtbl) = b1cacc4018241014d8c3ad5deacd16af
Error: Package: ocaml-camlidl-1.05-34.el7.centos.x86_64 (sergiomb-google-drive-ocamlfuse)
Requires: ocaml(Callback) = 198fb4bcde892143b0866b03cfae8085
Available: ocaml-runtime-4.05.0-6.el7.x86_64 (base)
ocaml(Callback) = dce408881d6ac6161453b15efba2e1b4
Error: Package: ocaml-camlidl-1.05-34.el7.centos.x86_64 (sergiomb-google-drive-ocamlfuse)
Requires: ocaml(Obj) = b0adfa4175f86e4394859886c1a374bb
Available: ocaml-runtime-4.05.0-6.el7.x86_64 (base)
ocaml(Obj) = 08bac48fef2bdca984d647c3942da632
Error: Package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64 (sergiomb-google-drive-ocamlfuse)
Requires: ocaml(Callback) = 198fb4bcde892143b0866b03cfae8085
Available: ocaml-runtime-4.05.0-6.el7.x86_64 (base)
ocaml(Callback) = dce408881d6ac6161453b15efba2e1b4
Error: Package: ocaml-camlidl-1.05-34.el7.centos.x86_64 (sergiomb-google-drive-ocamlfuse)
Requires: ocaml(Int32) = ad06f04cfca6d404d1de76c3dc67324a
Available: ocaml-runtime-4.05.0-6.el7.x86_64 (base)
ocaml(Int32) = 9bbc1d113f6a37cdcc135f132a12dc30
Error: Package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64 (sergiomb-google-drive-ocamlfuse)
Requires: ocaml(List) = d757117653d9319fefb7ddc78a998f41
Available: ocaml-runtime-4.05.0-6.el7.x86_64 (base)
ocaml(List) = d811c92e8d74500368d113948b851641
Error: Package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64 (sergiomb-google-drive-ocamlfuse)
Requires: ocaml(Condition) = 7e8a9025f5f5369f8af64bb2d24f1bc5
Available: ocaml-runtime-4.05.0-6.el7.x86_64 (base)
ocaml(Condition) = 738160777e3fef89b7e1498c9887be1d
Error: Package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64 (sergiomb-google-drive-ocamlfuse)
Requires: ocaml(Array) = 8a6bb22925744456eb66180ea42e3344
Available: ocaml-runtime-4.05.0-6.el7.x86_64 (base)
ocaml(Array) = b801116cd919b6519c3585bcf595e7e8
Error: Package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64 (sergiomb-google-drive-ocamlfuse)
Requires: ocaml(Thread) = 9c6f664141b325633a43fee33cfc2f6d
Available: ocaml-runtime-4.05.0-6.el7.x86_64 (base)
ocaml(Thread) = 9495c0cc18ca2325b9665257036fe5ae
ocaml(Thread) = 9393b4b7b641cc24953ddbc221106952
Error: Package: ocamlfuse-2.7.1-5.cvs5.el7.centos.x86_64 (sergiomb-google-drive-ocamlfuse)
Requires: ocaml(Mutex) = bf9c20efca54afdc260604f8bb20c0e9
Available: ocaml-runtime-4.05.0-6.el7.x86_64 (base)
ocaml(Mutex) = 74609296cc418d144620c7d4fadb6feb
Error: Package: ocaml-camlidl-1.05-34.el7.centos.x86_64 (sergiomb-google-drive-ocamlfuse)
Requires: ocaml(Pervasives) = 36b5bc8227dc9914c6d9fd9bdcfadb45
Available: ocaml-runtime-4.05.0-6.el7.x86_64 (base)
ocaml(Pervasives) = 07ea9e20ae94d62c35cfecbe7d66d3ea
You could try using --skip-broken to work around the problem
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Rsyncing to Google Drive Using google-drive-ocamlfuse scottm7 Linux - Newbie 5 10-27-2017 01:34 PM
LXer: Mount Google Drive On Linux With Google Drive Ocamlfuse Client LXer Syndicated Linux News 0 09-11-2017 02:25 PM
error while installing unixODBC-2.2.14 on AIX 5.3 -configure: error: C compiler canno sriram_nittala AIX 0 01-20-2010 04:18 AM
error when installing gift: error: cannot compute sizeof (short), 77 v1pEr Linux - Software 5 11-04-2004 03:43 AM
ERROR running make when installing Nvidia drivers (syntax error) randyriver10 Linux - Software 5 02-21-2004 05:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration