LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Error in installing Skim-1.4.4 (https://www.linuxquestions.org/questions/linux-software-2/error-in-installing-skim-1-4-4-a-486210/)

Alvin Voo 09-23-2006 06:19 AM

Error in installing Skim-1.4.4
 
Hello,
I am a totally newbie in Linux and just installed it a couple days ago.
Wanted to type in Chinese and read about skim so decided to give it a try, but here is the problem. I have installed scim-1.4.4 and Qt 4.1.4 and after i run ./configure, everything was fine but when i tried to compile it by make or ./scons, here's what it gave me:
KeyError: 'SCIM_X11_LIBS':
File "SConstruct", line 163:
env.subdirs(dirs)
File "./bksys/generic.py", line 619:
lenv.SConscript(lenv.join(i, 'SConscript'))
File "/home/xoalvinox/skim-1.4.5/scons-local-0.96.1/SCons/Script/SConscript.py", line 311:
return apply(_SConscript, [self.fs,] + files, {'exports' : exports})
File "/home/xoalvinox/skim-1.4.5/scons-local-0.96.1/SCons/Script/SConscript.py", line 134:
exec _file_ in stack[-1].globals
File "src/SConscript", line 11:
srcenv.AppendUnique(LINKFLAGS = env['SCIM_X11_LIBS'])
File "/home/xoalvinox/skim-1.4.5/scons-local-0.96.1/SCons/Environment.py", line 147:
return self._dict[key]
make: *** [all] Error 2
Is there something wrong with the scim libraries? Or do i need extra scim libraries for it to compile? Thanks.


All times are GMT -5. The time now is 03:14 AM.