-   Linux - Software (
-   -   Error enabling 1600x900@60Hz resolution in xorg.conf (

jrdioko 10-18-2009 06:05 PM

Error enabling 1600x900@60Hz resolution in xorg.conf
I just got a new system with a Dell ST2010F widescreen display. After going through Debian's standard install, I've wound up with a resolution of 1024x768. After some Xorg research, I came up with the following xorg.conf:


Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc104"
        Option          "XkbLayout"    "us"
        Option          "XkbOptions"    "ctrl:swapcaps"

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"

Section "Device"
        Identifier      "Configured Video Device"
        Option          "UseFBDev"              "true"

Section "Monitor"
        Identifier      "Configured Monitor"
        Modeline        "1600x900" 97.75 1600 1648 1680 1760 900 903 908 926 +hsync -vsync

Section "Screen"
        Identifier      "Default Screen"
        Monitor        "Configured Monitor"
        Device          "Configured Video Device"
        DefaultDepth 24
        Subsection "Display"
                Depth      24
                Modes "1600x900" "1024x768" "800x600" "640x480"

However, when I restart X with this configuration, I get the following messages in my /var/log/Xorg.0.log:


(II) VESA(0): Total Memory: 256 64KB banks (16384kB)
(II) VESA(0): Configured Monitor: Using hsync range of 30.00-83.00 kHz
(II) VESA(0): Configured Monitor: Using vrefresh range of 56.00-76.00 Hz
(II) VESA(0): Configured Monitor: Using maximum pixel clock of 170.00 MHz
(II) VESA(0): Not using mode "1600x900" (no mode of this name)
(II) VESA(0): Not using built-in mode "1920x1440" (width too large for virtual size)
(II) VESA(0): Not using built-in mode "1856x1392" (width too large for virtual size)
(II) VESA(0): Not using built-in mode "1792x1344" (width too large for virtual size)
(II) VESA(0): Not using built-in mode "1600x1200" (width too large for virtual size)

There very clearly is a mode in the xorg.conf named "1600x900", so I don't know where that message is coming from... Any idea what I'm doing wrong?

the trooper 10-18-2009 06:42 PM

I don't think the Vesa driver can run to that high a resolution.
Is there a particular reason you are using the Vesa driver?.
The output of lspci | grep VGA would be helpful.

jrdioko 10-18-2009 07:31 PM

Ah ok. My video card is an ATI Radeon HD 4350 (512 mb). I was trying to fix the resolution before I tried tackling the special-video-driver issue, but I guess I need to do both at once.

Here's the lspci output:


01:00.0 VGA compatible controller: ATI Technologies Inc Device 954f (prog-if 00 [VGA controller])
Using the xorg.conf above, I added:


Driver "radeonhd"
in the "Device" section. Restarting gdm fails with the following in the Xorg log:


(II) LoadModule: "kbd"
(II) Loading /usr/lib/xorg/modules/input//
(II) Module kbd: vendor="X.Org Foundation"
        compiled for, module version = 1.3.1
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 2.0
(II) RADEONHD: X driver for the following AMD GPG (ATI) graphics devices:
        RV505 : Radeon X1550, X1550 64bit.
        RV515 : Radeon X1300, X1550, X1600; FireGL V3300, V3350.
        RV516 : Radeon X1300, X1550, X1550 64-bit, X1600; FireMV 2250.
        R520  : Radeon X1800; FireGL V5300, V7200, V7300, V7350.
        RV530 : Radeon X1300 XT, X1600, X1600 Pro, X1650; FireGL V3400, V5200.
        RV535 : Radeon X1300, X1650.
        RV550 : Radeon X2300 HD.
        RV560 : Radeon X1650.
        RV570 : Radeon X1950, X1950 GT; FireGL V7400.
        R580  : Radeon X1900, X1950; AMD Stream Processor.
        R600  : Radeon HD 2900 GT/Pro/XT; FireGL V7600/V8600/V8650.
        RV610 : Radeon HD 2350, HD 2400 Pro/XT, HD 2400 Pro AGP; FireGL V4000.
        RV620 : Radeon HD 3450, HD 3470.
        RV630 : Radeon HD 2600 LE/Pro/XT, HD 2600 Pro/XT AGP; Gemini RV630;
                FireGL V3600/V5600.
        RV635 : Radeon HD 3650, HD 3670.
        RV670 : Radeon HD 3690, 3850, HD 3870, FireGL V7700, FireStream 9170.
        R680  : Radeon HD 3870 X2.
        M52  : Mobility Radeon X1300.
        M54  : Mobility Radeon X1400; M54-GL.
        M56  : Mobility Radeon X1600; Mobility FireGL V5200.
        M58  : Mobility Radeon X1800, X1800 XT; Mobility FireGL V7100, V7200.
        M62  : Mobility Radeon X1350.
        M64  : Mobility Radeon X1450, X2300.
        M66  : Mobility Radeon X1700, X1700 XT; FireGL V5250.
        M68  : Mobility Radeon X1900.
        M71  : Mobility Radeon HD 2300.
        M72  : Mobility Radeon HD 2400; Radeon E2400.
        M74  : Mobility Radeon HD 2400 XT.
        M76  : Mobility Radeon HD 2600;
                (Gemini ATI) Mobility Radeon HD 2600 XT.
        M82  : Mobility Radeon HD 3400.
        RS600 : Radeon Xpress 1200, Xpress 1250.
        RS690 : Radeon X1200, X1250, X1270.

(II) RADEONHD: version 1.2.1, built from non-git sources

(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(EE) No devices detected.

Fatal server error:
no screens found

Googling that error gets me nowhere. Is my card not supported by that driver yet?

the trooper 10-18-2009 07:42 PM

The Vesa driver is a last resort,typically it will work with most video devices but give fairly poor performance.
The following guide is helpful for installing the Ati drivers with Debian:

I believe you will need to use the proprietary driver to get the best from your graphics card and monitor.

jrdioko 10-18-2009 11:27 PM

I followed the steps to install the fglrx proprietary driver (at a different place actually, here:, and everything immediately worked correctly. I was even able to get rid of the modeline and all the custom xorg.conf stuff I've been fiddling with and it still auto-detects it.

Thanks for your help!

the trooper 10-19-2009 05:06 AM

Glad to hear you got it working!.
It would be useful if you use the thread tools at the top right of the page and mark it solved.

jrdioko 10-19-2009 11:01 AM


Originally Posted by the trooper (Post 3724667)
Glad to hear you got it working!.
It would be useful if you use the thread tools at the top right of the page and mark it solved.

Ah, LQ has come a long way since I used to use it a couple years ago. I'll go do that now.

All times are GMT -5. The time now is 04:23 AM.