LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-29-2011, 03:44 AM   #16
udaiya
LQ Newbie
 
Registered: Jul 2011
Posts: 15

Original Poster
Rep: Reputation: Disabled

so can i use cent OS 5.6 for my project.have u tried along with the ns2hcca patch


Quote:
Originally Posted by knudfl View Post
No luck on Ubuntu 10.04 Lucid, 64bits with ns-2.29.3 + ns2hcca-2.29-060823.patch.
http://cng1.iet.unipi.it/archive/ns2...60823.patch.gz

I also get the error ""`.gnu.linkonce.t._ZN11taskPending10taskStatusEh' referenced
in section `.rodata' of wpan/p802_15_4mac.o: defined in discarded section""


CentOS 5.6, 32bits : No errors.

All later ns2 versions were originally built and tested on RHEL5, CentOS 5.
Usually there are workarounds for Ubuntu. Don't know any for this patch.
Have tried with g++-3.3, g++-3.4, g++-4.1 : Errors.
An un-patched ns-2.29.3, and ns-2.29.3 with other patches : No problems.

..
 
Old 07-29-2011, 05:37 AM   #17
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,399

Rep: Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611
Quote:
.. use cent OS 5.6 for my project. Have you tried along with the ns2hcca patch
Yes, that's what I did yesterday, ref. post #15: No errors with ns2hcca added.

A 32bits OS should be preferred. All ns2 come with a slightly reduced result
( 'validate' / make test ) on a 64bits OS.
 
Old 07-29-2011, 07:04 AM   #18
udaiya
LQ Newbie
 
Registered: Jul 2011
Posts: 15

Original Poster
Rep: Reputation: Disabled
installation steps?

Thank you so much.and do i have to follow the same procedure as ubuntu or something else for centOS 5.6 32-bit

cd ns-allinone-2.29/ && export CC=gcc-3.4 CXX=g++-3.4 &&
cd ns-allinone-2.xx/ns-2.xx/ && make clean.
./install
Do i have to use gcc 3.4 or something else

regards
udai


Quote:
Originally Posted by knudfl View Post
Yes, that's what I did yesterday, ref. post #15: No errors with ns2hcca added.

A 32bits OS should be preferred. All ns2 come with a slightly reduced result
( 'validate' / make test ) on a 64bits OS.
 
Old 07-29-2011, 07:14 AM   #19
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,399

Rep: Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611
# 18. For CentOS 5 :

# yum install \
gcc-c++ compat-gcc-34-c++ automake autoconf libtool libX11-devel \
libXext-devel libXau-devel libXmu-devel xorg-x11-proto-devel

And gcc 3.4 / g++ 3.4 have different names :

cd ns-allinone-2.29/ && export CC=gcc34 CXX=g++34 && ./install

Quote:
cd ns-allinone-2.xx/ns-2.xx/ && make clean
The application is clean, when you start. 'make clean' is only used,
If you change something, and want to recompile.

..
 
Old 07-29-2011, 07:27 AM   #20
udaiya
LQ Newbie
 
Registered: Jul 2011
Posts: 15

Original Poster
Rep: Reputation: Disabled
Thanks. now i am downloading cent OS 5.6 32-bit.
let me try to install ns 2.29.3 on that and send u the update soon.
once again thank u soo much


Quote:
Originally Posted by knudfl View Post
# 18. For CentOS 5 :

# yum install \
gcc-c++ compat-gcc-34-c++ automake autoconf libtool libX11-devel \
libXext-devel libXau-devel libXmu-devel xorg-x11-proto-devel

And gcc 3.4 / g++ 3.4 have different names :

cd ns-allinone-2.29/ && export CC=gcc34 CXX=g++34 && ./install


The application is clean, when you start. 'make clean' is only used,
If you change something, and want to recompile.

..
 
Old 08-01-2011, 02:16 AM   #21
udaiya
LQ Newbie
 
Registered: Jul 2011
Posts: 15

Original Poster
Rep: Reputation: Disabled
Thanks

Hi friend
It worked for me in cent OS-5.6.
Thank You so much for your comments and your effort towards solving the problem.
I need one more suggestion.
I am using Acer aspire 4810T with 6-cell Li-ion battery.
When i am using Windows i dont find any problem.But when i switch to Ubuntu,Fedora or CentOs,
Power option is not working for me.It always says Laptop battery is charged(100%).
Is there any other solution.
Once again Thanks .You saved me.

Thanks
Kind Regards
Udai


Quote:
Originally Posted by knudfl View Post
# 18. For CentOS 5 :

# yum install \
gcc-c++ compat-gcc-34-c++ automake autoconf libtool libX11-devel \
libXext-devel libXau-devel libXmu-devel xorg-x11-proto-devel

And gcc 3.4 / g++ 3.4 have different names :

cd ns-allinone-2.29/ && export CC=gcc34 CXX=g++34 && ./install


The application is clean, when you start. 'make clean' is only used,
If you change something, and want to recompile.

..
 
Old 08-01-2011, 04:19 AM   #22
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,399

Rep: Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611Reputation: 3611
Quote:
.. Ubuntu,Fedora or CentOs, Power option is not working for me.
It always says Laptop battery is charged (100%).
Not about ns2. → New topic. Please start a new thread. Then somebody will answer.


( Also : It's not an issue, I know anything about.)

..
 
Old 08-01-2011, 05:17 AM   #23
udaiya
LQ Newbie
 
Registered: Jul 2011
Posts: 15

Original Poster
Rep: Reputation: Disabled
Ok I do

Sure. I will do that.Thanks

Quote:
Originally Posted by knudfl View Post
Not about ns2. → New topic. Please start a new thread. Then somebody will answer.


( Also : It's not an issue, I know anything about.)

..
 
Old 08-16-2011, 12:39 PM   #24
AnasAmer
LQ Newbie
 
Registered: Aug 2011
Posts: 15

Rep: Reputation: Disabled
can ns2.29 be installed on ubuntu 10.04

Hi guys
I am trying to simulate wireless sensor network on ns2 with ubuntu 10.04 but i dont know which version of ns2 to be used
I tried the 2.29 and 2.34 but i always have the error
wrong node routing agent when i try to simulate any sensing example because of the phenom routing agent
Plz help
Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration