LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-10-2004, 05:48 PM   #1
Boby
Member
 
Registered: Feb 2004
Posts: 781

Rep: Reputation: Disabled
Error compiling PHP-5.0.1 with MySQL


Hello!

I want to compile PHP-5.0.1 with MySQL. Have allready compiled and installed Apache 2.50 (in /usr/local/Apache2) and MySQL 4.20 (in /usr/local/mysql-standard-4.0.20-pc-linux-i686). Now when I want to compile PHP5 I'll use:
./configure --with-apxs2=/usr/local/Apache2/bin/apxs --with-mysql
but I get this error:
Code:
checking for MySQL support... yes
checking for specified location of the MySQL UNIX socket... no
checking for MySQL UNIX socket location... /tmp/mysql.sock
configure: error: Cannot find MySQL header files under yes.
Note that the MySQL client library is not bundled anymore.
If I give --with-mysql the directory it won't work too:
./configure --with-apxs2=/usr/local/Apache2/bin/apxs --with-mysql-dir=/usr/local/mysql-standard-4.0.20-pc-linux-i686
Then I get this:
Code:
checking for mSQL support... no
checking for MSSQL support via FreeTDS... no
checking for MySQL support... no
checking for specified location of the MySQL UNIX socket... no
checking for MySQLi support... no
checking whether to enable embedded MySQLi support... no

.............

Generating files
updating cache ./config.cache
creating ./config.status
creating php5.spec
creating main/build-defs.h
creating scripts/phpize
creating scripts/php-config
creating sapi/cli/php.1
creating main/php_config.h
main/php_config.h is unchanged
creating main/internal_functions.c
creating main/internal_functions_cli.c
+--------------------------------------------------------------------+
| License:                                                           |
| This software is subject to the PHP License, available in this     |
| distribution in the file LICENSE.  By continuing this installation |
| process, you are bound by the terms of this license agreement.     |
| If you do not agree with the terms of this license, you must abort |
| the installation process at this point.                            |
+--------------------------------------------------------------------+

Thank you for using PHP.
What should I do to have PHP5 succesfully compiled with MySQL?
Thank you!

Boby

Last edited by Boby; 09-10-2004 at 06:33 PM.
 
Old 09-10-2004, 07:01 PM   #2
KohlyKohl
Member
 
Registered: Aug 2004
Location: Wausau, WI
Distribution: SuSE Linux Enterprise Desktop 10
Posts: 193

Rep: Reputation: 30
I suggest you save yourself alot of time and just install Lampp aka Xampp for Linux. You don't have to install anything its ready as soon as its unpacked. It included the newest apache mysql php and much more. Its rediculous how easy this script is to use, and the headache you get when trying to install all of these on your own is just stupid. http://www.apachefriends.org/en/xampp.html
 
Old 09-10-2004, 09:05 PM   #3
Boby
Member
 
Registered: Feb 2004
Posts: 781

Original Poster
Rep: Reputation: Disabled
no no... I want them compiled by myself

thanks anyway!
boby
 
Old 09-10-2004, 09:17 PM   #4
KohlyKohl
Member
 
Registered: Aug 2004
Location: Wausau, WI
Distribution: SuSE Linux Enterprise Desktop 10
Posts: 193

Rep: Reputation: 30
God only knows why you would even care to do that. Its been a while but i'd try pointing it to the mysql/bin directory.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
php5 ./configure error: Cannot find MySQL header files ldp Linux - Software 29 05-15-2018 04:30 PM
Error compiling perl-DBD-MySQL after upgrading to MySQL 4.1 pitaro920 Linux - Software 1 01-16-2006 04:28 PM
Compiling PHP5 Terroth Linux - Newbie 2 06-27-2005 01:35 PM
PHP5 compiling problems Ephracis Linux - Software 10 02-10-2005 01:45 PM
Compiling PHP5 on FC2 imemyself Linux - Software 0 10-09-2004 06:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration